SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002205: Clamav Autoupdater doesn´t work - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002205Endian FirewallOther Servicespublic2009-09-25 02:102009-10-27 11:58
ReporterRenee 
Assigned Tosimon-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3-rc1 
Target VersionFixed in Version2.3 
Summary0002205: Clamav Autoupdater doesn´t work
DescriptionThe Clamav Autoupdater probably does not function because the start script for freshclam in the cron.xxx directory not existed because it not is provided if the autoupdate option is activated.
TagsNo tags attached.
Attached Files

- Relationships
related to 0002211closedsimon-endian clamav always starts and no service relaying on clamav ever enables clamav to be started 

-  Notes
(0003003)
goreXP (reporter)
2009-09-25 04:42

I second that.
(0003004)
Renee (reporter)
2009-09-25 11:49

I have ascertained in the Cron.xxx to lists of the Symlink to /usr/lib/clamav/freshclam.cron is not provided, however, a manual one provide does not seem to go because the system for the Symlink apparently independently again extinguishes.
(0003005)
Renee (reporter)
2009-09-25 13:24
edited on: 2009-09-25 15:13

The update Script /usr/lib/clamav/freshclam.cron do not work I created a Symlink with new name in /etc/cron.hourly/ directly to
/usr/bin/freshclam that works.

Quick fix:

ln -s /usr/bin/freshclam /etc/cron.hourly/freshclamav

(0003006)
goreXP (reporter)
2009-09-25 13:41

Yes, but take a look at the end of the file /usr/local/bin/restartfreshclam.py

if config_values['UPDATE_SCHEDULE'] in ['hourly', 'weekly', 'daily', 'monthly']:
    target = path.join("/etc/anacron." + config_values['UPDATE_SCHEDULE'], "freshclam")
    os.symlink(SCRIPT, target)

### and add:

    target = path.join("/etc/cron." + config_values['UPDATE_SCHEDULE'], "freshclam")
    os.symlink(SCRIPT, target)
(0003007)
Renee (reporter)
2009-09-25 13:55

Work that? I have the problem that /usr/lib/clamav/freshclam.cron does not work at /etc/anacron.hourly/ the the symlink exist but the script does not work.
(0003012)
peter-endian (administrator)
2009-09-25 15:55

anacron is only another type of cron, which does not count from 0:00, but from when the fcron process is started. So you have a little bit of random, which is good for freshclam, otherwise all installations would update at exactly the same time.

I analyzed a little bit the issue. Problem is that no service which relays on clamav actually does really start clamav. Those services need to touch /var/efw/clamav/enable_servicename
The freshclam cron script does not work because it exits when there's no such an enable flag-file.

Workaround:
touch /var/efw/clamav/enable_workaround

This however opens a much more severe bug.. Clamav will not formally be started, but starts all the time also if not needed.
(0003027)
simon-endian (developer)
2009-09-29 08:49

signatures are only updated if clamd is running

- Issue History
Date Modified Username Field Change
2009-09-25 02:10 Renee New Issue
2009-09-25 04:42 goreXP Note Added: 0003003
2009-09-25 11:49 Renee Note Added: 0003004
2009-09-25 13:24 Renee Note Added: 0003005
2009-09-25 13:41 goreXP Note Added: 0003006
2009-09-25 13:55 Renee Note Added: 0003007
2009-09-25 15:12 Renee Note Edited: 0003005
2009-09-25 15:13 Renee Note Edited: 0003005
2009-09-25 15:55 peter-endian Note Added: 0003012
2009-09-25 15:55 peter-endian Assigned To => simon-endian
2009-09-25 15:55 peter-endian Status new => confirmed
2009-09-25 16:00 peter-endian Relationship added related to 0002211
2009-09-29 08:49 simon-endian Note Added: 0003027
2009-09-29 08:49 simon-endian Status confirmed => resolved
2009-09-29 08:49 simon-endian Fixed in Version => 2.3
2009-09-29 08:49 simon-endian Resolution open => fixed
2009-10-27 11:58 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker