SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002288: disk is full!!! - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002288Endian FirewallProxy HTTPpublic2009-10-23 06:572009-10-27 11:58
Reportertyrorare 
Assigned Toluca-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3-rc1 
Target VersionFixed in Version2.3 
Summary0002288: disk is full!!!
DescriptionI have 20 Gb disk. And automaticaly it's make / folder 942 m, /var - 18608, /var/efw -101 m, and /var/log -302. So ... Now /var/log is full. It 's is too litle for storing log files. Maybe I make mistake when install endian?
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0002176closedpeter-endian partition sizes are fixed to NON-RAID and a small size and not calculated during installation 

-  Notes
(0003139)
goreXP (reporter)
2009-10-23 20:17

Same here.
(0003140)
luca-endian (developer)
2009-10-23 22:34

Can you post the output of the following commands:

df -h
du -ak /var/log | sort -n -r | head -n 10
du -h --max-depth=1 /var/log
(0003141)
tyrorare (reporter)
2009-10-24 10:18

df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 942M 601M 294M 68% /
/dev/sda6 19G 538M 17G 4% /var
/dev/sda3 101M 5.0M 91M 6% /var/efw
/dev/sda5 302M 94M 192M 33% /var/log

du -ak /var/log | sort -n -r | head -n 10
79784 /var/log
36076 /var/log/httpd
26664 /var/log/messages
19072 /var/log/httpd/ssl_engine_log
8836 /var/log/httpd/ssl_request_log
8008 /var/log/httpd/httpd_access
6036 /var/log/maillog
4720 /var/log/firewall
3344 /var/log/maillog_short
848 /var/log/squid

du -h --max-depth=1 /var/log
16K /var/log/lost+found
116K /var/log/clamav
4.0K /var/log/openvpn
8.0K /var/log/frox
320K /var/log/ip-acct
4.0K /var/log/pyzord
36M /var/log/httpd
4.0K /var/log/dansguardian
848K /var/log/squid
20K /var/log/havp
4.0K /var/log/fifo
4.0K /var/log/spamd
84K /var/log/logwatch
4.0K /var/log/ppp
628K /var/log/snort
4.0K /var/log/ulogd
4.0K /var/log/samba
560K /var/log/rrd
8.0K /var/log/snmpd
4.0K /var/log/iptraf
78M /var/log


B4t before I used proxy log, Now I check proxy log out
(0003142)
tyrorare (reporter)
2009-10-24 10:20

And else... When disk was full I can't start proxy server. I think it's normal :)
(0003143)
luca-endian (developer)
2009-10-25 09:35

I see, problem is that your /var/log is too small it shouldn't be in that way.
(0003144)
tyrorare (reporter)
2009-10-25 10:52

I see that too :) But why it's so small? Only I have that size or other peaple have the same size?
(0003146)
danodemano (reporter)
2009-10-26 11:25
edited on: 2009-10-26 11:29

My /var/log is the same size (302MB), and I have a 360GB hard drive in my Endian machine. The installer made it that size and didn't give an option. I started a topic on efwsupport about this very issue: http://efwsupport.com/index.php?PHPSESSID=dadecb08f6d9b8a5a89fce13055795e5&topic=959.0 [^]

(0003147)
luca-endian (developer)
2009-10-26 12:13

Ok it sounds like a bug while creating partition, /var/log shouldn't be a fixed size but a percentage of the disk.

Something went wrong between beta and rc...

This is how it should be (on a upgraded beta):
root@firewall:~ # df -h
Filesystem Size Used Avail Use% Mounted on
/dev/hda1 6.0G 751M 5.0G 13% /
/dev/hda6 19G 674M 17G 4% /var
/dev/hda3 99M 5.4M 89M 6% /var/efw
/dev/hda5 12G 163M 12G 2% /var/log

This is a fresh RC1 installation:
root@kenny:~ # df -h
Filesystem Size Used Avail Use% Mounted on
/dev/hda1 936M 580M 309M 66% /
/dev/hda6 36G 237M 34G 1% /var
/dev/hda3 99M 5.2M 89M 6% /var/efw
/dev/hda5 296M 22M 260M 8% /var/log
(0003149)
luca-endian (developer)
2009-10-26 16:17

This is fixed in 2.3 community final.

I'm afraid that a fix will be available only with a clean reinstall of the upcoming stable version.

- Issue History
Date Modified Username Field Change
2009-10-23 06:57 tyrorare New Issue
2009-10-23 20:17 goreXP Note Added: 0003139
2009-10-23 22:34 luca-endian Note Added: 0003140
2009-10-24 10:18 tyrorare Note Added: 0003141
2009-10-24 10:20 tyrorare Note Added: 0003142
2009-10-25 09:35 luca-endian Note Added: 0003143
2009-10-25 10:52 tyrorare Note Added: 0003144
2009-10-26 11:25 danodemano Note Added: 0003146
2009-10-26 11:29 danodemano Note Edited: 0003146
2009-10-26 12:13 luca-endian Note Added: 0003147
2009-10-26 12:13 luca-endian Status new => confirmed
2009-10-26 15:01 peter-endian Relationship added duplicate of 0002176
2009-10-26 16:17 luca-endian Note Added: 0003149
2009-10-26 17:56 luca-endian Status confirmed => resolved
2009-10-26 17:56 luca-endian Fixed in Version => 2.3
2009-10-26 17:56 luca-endian Resolution open => fixed
2009-10-26 17:56 luca-endian Assigned To => luca-endian
2009-10-27 11:58 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker