SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000230: Proxy logging issue in 2.1.2 - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000230Endian FirewallApplication Level Proxiespublic2007-07-27 14:412007-12-31 19:15
ReporterThomas Heimann 
Assigned Tora-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.1 
Target VersionFixed in Version2.2-beta2 
Summary0000230: Proxy logging issue in 2.1.2
DescriptionPosted in EFW Help Forum

https://sourceforge.net/forum/message.php?msg_id=4429840 [^]

All rotated proxy access logs are visible in the webinterface only new / active logs are not visible in the web interface.
 
As far as i see the problem is the ownership / umask of
active logs. The active log is owned by user squid with group
squid. Owner has read write access the group has read accessright and
all others have no access inclusive root.
So the cgi has no access to the active log.
 
I will try a quick fix by modifying /etc/logrotate.d/squid
 
I have added a line after
 
/bin/chmod -R ugo+rX /var/log/squid
/usr/sbin/squid -k rotate
 
The line is:
 
/bin/chmod a+r /var/log/squid/*
 
This should make the new log readable for root after rotation.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000568)
peter-endian (administrator)
2007-10-27 20:32

squid uses syslog-ng now, which creates the files with the correct permission

- Issue History
Date Modified Username Field Change
2007-07-27 14:41 Thomas Heimann New Issue
2007-08-06 14:37 raphael-endian Status new => assigned
2007-08-06 14:37 raphael-endian Assigned To => ra-endian
2007-10-27 20:32 peter-endian Status assigned => resolved
2007-10-27 20:32 peter-endian Fixed in Version => 2.2
2007-10-27 20:32 peter-endian Resolution open => fixed
2007-10-27 20:32 peter-endian Note Added: 0000568
2007-12-31 19:15 raphael-endian Fixed in Version 2.2-beta1 => 2.2-beta2
2007-12-31 19:15 raphael-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker