SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002300: Content Filter does not work - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002300Endian FirewallProxy HTTPpublic2009-10-27 19:502010-09-21 18:17
ReporterRenee 
Assigned Tosimon-endian 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3 
Target Version2.3.1Fixed in Version2.3.1 
Summary0002300: Content Filter does not work
DescriptionThe content filter does not work the dansguardian starts but the blacklists have no effect.
TagsNo tags attached.
Attached Filesjpg file icon workdone.JPG [^] (145,848 bytes) 2009-10-30 03:06

- Relationships
related to 0002299closedRenee Havp won´t start 

-  Notes
(0003177)
Renee (reporter)
2009-10-29 16:27

I search for the error but I found nothing the blacklists exist in /etc/dansguardian/blacklists but dansguardian ignores the blacklists largely and allows to pass itself sides although they blacklistet are and also to block are marked.
(0003179)
simon-endian (developer)
2009-10-29 16:42

did you create a contentfilter profile and did you create an access policy which uses that contentfilter profile for filter profile.

also check if you have an access rule with higher priority which allows the access.

to test it is best to have only one access rule which uses the contentfilter profile (you could disable all other rules to test)
(0003180)
peter-endian (administrator)
2009-10-29 16:53

so this can also be closed?
(0003184)
Renee (reporter)
2009-10-29 17:29
edited on: 2009-10-29 18:19

No it can not closed, yes a have used the standart contentfilter profile and I used the the Standart access policy with filter using 'content1 and no other access rules exist I used the same configuration as with 2.3 Rc1 and there it has functioned.The filter seems to be work but not correctly at example at www.heise.de I have an Input from the blacklist but even not all and at www.computerbase.de it show all the ads from sites although they blacklistet.

//edit/ Can this be the Dansguardian simply the Ips any more cannot determine because sees just most Domains stand as an Ip address in the Blacklist?

@Peter this problem also exists after a new installation where no backup I was played in specially everything has made new once more.

I have tested it again the user-defined black and whitelist works but there it also does not seem to be taken over with the first one sometimes.But the Blacklisten do not function at all, for example, cracks.am stands in the Spyware Blacklist also on block, however, it was put I can access, nevertheless, easily the side.

(0003200)
Renee (reporter)
2009-10-30 21:32
edited on: 2009-10-30 22:55

I found the problem the url blacklists works but dansguardian ignores the domain blacklists and this is a very big problem.

/edit/ I found the problem the endian config write the blacklist url entries to /etc/dansguardian/profiles/1/bannedurllist but not the domains entries to /etc/dansguardian/profiles/1/bannedsitelist this file was empty I wrote my entries manually to the file now works the blacklisting.
The config also del by hand provided entries from bannedsitelist again as soon as a change in the profile I am made the problem has avoided first while I have changed the path for bannedsitelist in the conf files.

(0003226)
mrkroket (reporter)
2009-11-03 17:21

The problem is that when they add the option to custom whitelists and blacklists, they broke the non-custom blacklists.

The solution could be to edit the /usr/local/bin/restartdansguardian.py and change the lines 308 and 319:

Line 308: exceptionsitefile = open("/etc/dansguardian/profiles/%s/exceptionsitelist" % number, "w")
Line 319: bannedsitefile = open("/etc/dansguardian/profiles/%s/bannedsitelist" % number, "w")

Change the "w" to "a". That will append custom site lists instead of overwriting them.
(0003257)
arcanos (reporter)
2009-11-05 16:41

I've just confirmed this bug. With a 2.3 new installation non-custom blacklist don't work.

Solution commented by mrkroket works.
(0003407)
simon-endian (developer)
2009-11-26 18:23

now custom blacklist does not overwrite the entries of bannedsitelist anymore

- Issue History
Date Modified Username Field Change
2009-10-27 19:50 Renee New Issue
2009-10-29 16:27 Renee Note Added: 0003177
2009-10-29 16:42 simon-endian Note Added: 0003179
2009-10-29 16:53 peter-endian Relationship added related to 0002299
2009-10-29 16:53 peter-endian Note Added: 0003180
2009-10-29 16:53 peter-endian Status new => feedback
2009-10-29 17:29 Renee Note Added: 0003184
2009-10-29 17:36 Renee Note Edited: 0003184
2009-10-29 17:50 Renee Note Edited: 0003184
2009-10-29 18:19 Renee Note Edited: 0003184
2009-10-30 03:06 vaohama File Added: workdone.JPG
2009-10-30 21:32 Renee Note Added: 0003200
2009-10-30 21:32 Renee Note Edited: 0003200
2009-10-30 22:30 Renee Note Edited: 0003200
2009-10-30 22:55 Renee Note Edited: 0003200
2009-11-03 17:21 mrkroket Note Added: 0003226
2009-11-05 16:41 arcanos Note Added: 0003257
2009-11-05 22:55 peter-endian Status feedback => new
2009-11-05 22:55 peter-endian Assigned To => simon-endian
2009-11-05 22:56 peter-endian Status new => assigned
2009-11-25 09:03 christian-endian Relationship added child of 0002435
2009-11-25 17:36 peter-endian Target Version => 2.3.1
2009-11-26 16:50 simon-endian Relationship added related to 0002248
2009-11-26 16:50 simon-endian Relationship added related to 0002419
2009-11-26 16:51 simon-endian Relationship added related to 0002397
2009-11-26 16:51 simon-endian Relationship added related to 0002404
2009-11-26 16:52 simon-endian Relationship deleted related to 0002248
2009-11-26 16:52 simon-endian Relationship deleted related to 0002419
2009-11-26 16:53 simon-endian Relationship deleted related to 0002397
2009-11-26 16:53 simon-endian Relationship deleted related to 0002404
2009-11-26 18:23 simon-endian Note Added: 0003407
2009-11-26 18:23 simon-endian Status assigned => resolved
2009-11-26 18:23 simon-endian Fixed in Version => 2.3.1
2009-11-26 18:23 simon-endian Resolution open => fixed
2010-04-13 19:27 Anonymous Status resolved => feedback
2010-04-13 19:27 Anonymous Resolution fixed => reopened
2010-09-21 18:17 peter-endian Status feedback => closed
2010-09-21 18:17 peter-endian Resolution reopened => fixed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker