SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002314: DHCP fails start with CUSTOM DHCP-Option Field used - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002314Endian FirewallOther Servicespublic2009-10-29 10:112009-10-29 13:00
ReporterMysterious 
Assigned Tosimon-endian 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3 
Target VersionFixed in Version2.3.1 
Summary0002314: DHCP fails start with CUSTOM DHCP-Option Field used
DescriptionCustom DHCP Options wrote to the Custom Option Filed crashed dhcp server.
Example if i add:

option tftp-server-name "tftp.mydomain.de";

The "-Sign and .-Sign are not escaped and ends up as ""e; at the /etc/dhcpd.conf. That causes dhcpd not to restart.
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0002190closedsimon-endian Using quotes in "Custom configuration lines" boxes are translated to """ in config file. 
related to 0001824closedmax-endian Admin GUI password fails with $ in 
has duplicate 0002380closedsimon-endian DHCP server don't start if you have a paratemer in "Custom Configuration Lines" that has double quotes (") 

-  Notes
(0003165)
simon-endian (developer)
2009-10-29 12:16

can you please test with the patch of 0002190
(0003170)
simon-endian (developer)
2009-10-29 12:43
edited on: 2009-10-29 12:43

this is fixed with patch of 0002190.

(0003172)
Mysterious (reporter)
2009-10-29 13:00

Ok, this resolves my issue. thanks.

- Issue History
Date Modified Username Field Change
2009-10-29 10:11 Mysterious New Issue
2009-10-29 12:16 simon-endian Relationship added duplicate of 0002190
2009-10-29 12:16 simon-endian Note Added: 0003165
2009-10-29 12:18 peter-endian Relationship added related to 0001824
2009-10-29 12:19 peter-endian Status new => acknowledged
2009-10-29 12:43 simon-endian Note Added: 0003170
2009-10-29 12:43 simon-endian Note Edited: 0003170
2009-10-29 12:44 simon-endian Status acknowledged => resolved
2009-10-29 12:44 simon-endian Fixed in Version => 2.3.1
2009-10-29 12:44 simon-endian Resolution open => fixed
2009-10-29 12:44 simon-endian Assigned To => simon-endian
2009-10-29 13:00 Mysterious Note Added: 0003172
2009-10-29 13:00 Mysterious Status resolved => closed
2009-11-05 11:22 simon-endian Relationship added has duplicate 0002380

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker