SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002376: Scheduled Backups not working anymore - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002376Endian FirewallGUIpublic2009-11-05 09:512010-01-21 19:03
Reportermalkie 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionsuspended 
PlatformOSOS Version
Product Version2.2 
Target VersionFixed in Version 
Summary0002376: Scheduled Backups not working anymore
DescriptionScheduled Backups via GUI are not working.
Additional InformationNeither on my Macro X2 Cluster nor the Macro X2 in singlemode or the Community 2.3 is it possible to use the scheduled backup's. I put in daily scheduled Backup, only Current Config andon Harddisk (no USB-Stick).
If i do a manual backup it is working.
On my Mecury Cluster and a Mini it is working but there it was setup all like a Year ago. This is still working fine.

I checked the /etc/cron.daily and it looks like this:

lrwxrwxrwx 1 root root 29 Jun 29 09:26 autobackup -> /usr/lib/backup/autobackup.sh

is doing the backups. This link is in the Mecury-HA-Cluster and the Mini, but not in the MacroX2-HA-Cluster, the single Macro X2 or the Communityversion.

Can you please fix that this will work again via Gui? In the meanwhile can i just add these links on my EFW's where it is not working and it will afterwards? Is there a Problem for doing this in a HA-Cluster?

BTW. I have the same Problem with Snort. For updates i also need to put this in by hand int the cron.weekly.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0003242)
peter-endian (administrator)
2009-11-05 10:36

can you please send the output of:
grep restartbackup /etc/sudoers

it should be this:
nobody ALL=NOPASSWD: /usr/local/bin/restartbackup.py

Can you try to change from daily to weekly or to monthly in order to check if a re-save does not change anything? Especially on the community installation, since i tried it there right now and it is working for me.
(0003248)
malkie (reporter)
2009-11-05 11:21

nobody ALL=NOPASSWD: /usr/local/bin/restartbackup

Is on all EFW where it is not working

and on all working ones it is:

nobody ALL=NOPASSWD: /usr/local/bin/restartbackup.py

could the missing .py be the problem?
(0003250)
luca-endian (developer)
2009-11-05 11:42

On 2.3 system can you try without logs and logs archive if it works?
(0003251)
malkie (reporter)
2009-11-05 12:32

It is allready setup only to backup the config and nothing else.
I will set backups now on hourly on the community and on the macrox2 and see what happens again.

Also i will try at home on my private efw 2.3 community if it works there.

If you need access to check something via the endian-network you can contact me and i will provide you acess. The single Macro x2 is right now not in productive use.
(0003252)
malkie (reporter)
2009-11-05 14:21

I turned on hourly scheduled backup on the single Marco X2 and the community 2.3. Only thing i backup is the config. I waited now for round about 2 hours and it didn't do a backup. Any advice?
(0003253)
peter-endian (administrator)
2009-11-05 14:38

> could the missing .py be the problem?

yes, that missing .py is the problem.

you can edit the file:

nano /etc/sudoers

search for that line and add the .py


did you do an upgrade somehow? On my fresh 2.3 enterprise installation and on the community installation it was correct, so maybe it's related to some upgrade stuff
or is it a fresh installation?
(0003254)
luca-endian (developer)
2009-11-05 14:40

Malkie,

if you have problems on Endian 2.2 enterprise systems please open a support ticket you will be in touch directly with ours engineers.
(0003255)
malkie (reporter)
2009-11-05 14:58

No, i didn't do any upgrade. It is a straight install on the community edition. I will add this there and see if it works.
If this is good can i also add this on the enterprise version myself or is there any problem. Will this also be fine with the cluster?

Thanks for you're help. I will give you feedback tomorrow about the community edition. I will leave for today and head home.
(0003261)
malkie (reporter)
2009-11-06 07:26

Good Morning Gents,
it is working now on my community-version. I just added the .py as Peter suggested. Many thanks for that hint. I guess it is the same for the enterprise efw? Even for the cluster or do i have to take care there about anything special?

But still I'm wondering how it could happen that this got so wrong.
(0003262)
peter-endian (administrator)
2009-11-06 12:09

you can do that on the enterprise version, too.
on the cluster you need to do it manually on both machines, since this file will not be synchronized.

I'm also wondering how this happened, since on my reference installations it is correct. This was a bug before, but fixed before release of 2.3, that's why it is so strange. Hope that it is not an issue on the released images/iso. I will double-check that.
(0003263)
malkie (reporter)
2009-11-06 14:06
edited on: 2009-11-06 14:07

o.k. i changed that. I guess this will work now. If not i will write back to you. From my side this can be closed. I highly appreciate your quick help. thanks a lot.

(0003269)
malkie (reporter)
2009-11-09 09:06

Seems all to work fine now. Many thanks.
(0003270)
malkie (reporter)
2009-11-09 09:07

Problem fixed. Missing suffix .py in /etc/sudoers for nobody ALL=NOPASSWD: /usr/local/bin/restartbackup.py

- Issue History
Date Modified Username Field Change
2009-11-05 09:51 malkie New Issue
2009-11-05 10:36 peter-endian Note Added: 0003242
2009-11-05 10:36 peter-endian Status new => acknowledged
2009-11-05 10:36 peter-endian Status acknowledged => feedback
2009-11-05 11:21 malkie Note Added: 0003248
2009-11-05 11:42 luca-endian Note Added: 0003250
2009-11-05 11:43 luca-endian Relationship added related to 0002171
2009-11-05 12:32 malkie Note Added: 0003251
2009-11-05 14:21 malkie Note Added: 0003252
2009-11-05 14:38 peter-endian Note Added: 0003253
2009-11-05 14:40 luca-endian Note Added: 0003254
2009-11-05 14:58 malkie Note Added: 0003255
2009-11-06 07:26 malkie Note Added: 0003261
2009-11-06 12:09 peter-endian Note Added: 0003262
2009-11-06 14:06 malkie Note Added: 0003263
2009-11-06 14:07 malkie Note Edited: 0003263
2009-11-09 09:06 malkie Note Added: 0003269
2009-11-09 09:07 malkie Note Added: 0003270
2009-11-09 09:07 malkie Status feedback => resolved
2009-11-09 09:07 malkie Resolution open => fixed
2009-11-09 09:07 malkie Assigned To => malkie
2009-12-15 16:00 luca-endian Relationship deleted related to 0002171
2009-12-15 16:02 luca-endian Assigned To malkie =>
2009-12-15 16:02 luca-endian Status resolved => feedback
2009-12-15 16:02 luca-endian Resolution fixed => reopened
2010-01-21 19:03 peter-endian Status feedback => closed
2010-01-21 19:03 peter-endian Resolution reopened => suspended

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker