SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002454: openvpnclient in bridge mode does not bridge when no routing is configured - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002454Endian FirewallNetwork related (VPN, uplinks)public2009-11-26 16:322010-11-22 12:04
Reporterpeter-endian 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3 
Target Version2.3.1Fixed in Version2.3.1 
Summary0002454: openvpnclient in bridge mode does not bridge when no routing is configured
Descriptionif the file /var/efw/routing/config does not exist, means no routing is configured
the openvpnclient bridge script crashes and does not put the tap device within the configured bridge.

This happens because it is assumed that the datasource always returns iterators, but in this case, when a file does not exist it returns None, which causes a traceback.

Firewall rules then are created wrong, because physdev will be used (bridged mode) instead of -i (routed mode)
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2009-11-26 16:32 peter-endian New Issue
2009-11-26 16:32 peter-endian Assigned To => peter-endian
2009-11-26 16:33 peter-endian Status new => resolved
2009-11-26 16:33 peter-endian Fixed in Version => 2.3.1
2009-11-26 16:33 peter-endian Resolution open => fixed
2010-11-22 12:04 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker