SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002485: Dashboard doesn't show up VLAN rx & tx speed - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002485Endian FirewallGUIpublic2009-12-04 17:412010-11-22 12:06
Reportermrkroket 
Assigned Tosimon-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3 
Target Version2.3.1Fixed in Version2.3.1 
Summary0002485: Dashboard doesn't show up VLAN rx & tx speed
DescriptionVLAN in and out transmission speeds always appears on blank.
Tested on both a virtual and a physical machine, on 3 browsers:
 -Firefox
 -IE8
 -Opera

All have the same behaviour. Dashboard shows in & out speed of any interface except for VLANs
Tagspurple
Attached Files

- Relationships

-  Notes
(0003513)
mrkroket (reporter)
2009-12-04 17:53

It seems that the problem is in /home/httpd/html/include/dashboard.js at line [33]
To detect a NIC, the script uses a regexp:
         var nic_regex = /interface\/if_octets\-([a-z0-9]+)/;
That works fine with almost all interfaces, but not with vlan ones. VLANS have a dot (eth0.20), so the above regexp will never match. Changing to
         var nic_regex = /interface\/if_octets\-([\.a-z0-9]+)/;

Seems to correct the problem. Anyways that doesn't work on IE8, I don't know why. But it correctly shows both on Opera and Firefox
(0003779)
simon-endian (developer)
2010-02-15 04:08

tested and applied solution mentioned by mrkroket

- Issue History
Date Modified Username Field Change
2009-12-04 17:41 mrkroket New Issue
2009-12-04 17:53 mrkroket Note Added: 0003513
2009-12-07 17:57 peter-endian Assigned To => simon-endian
2009-12-07 17:57 peter-endian Status new => confirmed
2009-12-07 17:57 peter-endian Target Version => 2.3.1
2010-01-27 16:54 luca-endian Tag Attached: purple
2010-02-15 04:08 simon-endian Note Added: 0003779
2010-02-15 04:08 simon-endian Status confirmed => resolved
2010-02-15 04:08 simon-endian Fixed in Version => 2.3.1
2010-02-15 04:08 simon-endian Resolution open => fixed
2010-11-22 12:06 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker