SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002490: spamd eats all the memory - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002490Endian FirewallOther Servicespublic2009-12-08 01:012010-11-22 12:04
Reporterpeter-endian 
Assigned Topeter-endian 
PrioritynormalSeveritycrashReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3 
Target Version2.3.1Fixed in Version2.3.1 
Summary0002490: spamd eats all the memory
Descriptionwhen upgrading from 2.2 to 2.3, the berkley db of spamassassin's auto-whitelist will have to change format, since we upgrade db4.
perl-DB_File tries then to open that berkley db, but does not get the file-lock and thus tries to open in a recursive infinite loop, which eventually eat all the memory

Dec 8 01:32:38 MIGRATION spamd[6355]: locker: safe_lock: created /var/lib/spamassassin/auto-whitelist.lock.MIGRATION.localdomain.6355
Dec 8 01:32:38 MIGRATION spamd[6355]: locker: safe_lock: trying to get lock on /var/lib/spamassassin/auto-whitelist with 0 retries
Dec 8 01:32:39 MIGRATION spamd[6355]: locker: safe_lock: trying to get lock on /var/lib/spamassassin/auto-whitelist with 1 retries
[...]
Dec 8 01:33:06 MIGRATION spamd[6355]: locker: safe_lock: trying to get lock on /var/lib/spamassassin/auto-whitelist with 29 retries
Dec 8 01:33:06 MIGRATION spamd[6355]: auto-whitelist: tie-ing to DB file of type DB_File R/O in /var/lib/spamassassin/auto-whitelist
Dec 8 01:33:06 MIGRATION spamd[6355]: Use of uninitialized value in numeric gt (>) at /usr/lib/perl5/5.8.5/i386-linux-thread-multi/DB_File.pm line 271.
Dec 8 01:33:06 MIGRATION spamd[6355]: Deep recursion on subroutine "DB_File::AUTOLOAD" at /usr/lib/perl5/5.8.5/i386-linux-thread-multi/DB_File.pm line 234.


according this http://wiki.apache.org/spamassassin/DeepRecursionInDbFile [^]
it is simply necessary to upgrade perl-DB_File in order to match the db4 package.

TagsNo tags attached.
Attached Files

- Relationships
related to 0001532feedbackpeter-endian amavis: does not accept any connections due to db4 lock 

-  Notes
(0003524)
peter-endian (administrator)
2009-12-08 01:02

probably this update fixed also 0001532

- Issue History
Date Modified Username Field Change
2009-12-08 01:01 peter-endian New Issue
2009-12-08 01:01 peter-endian Assigned To => peter-endian
2009-12-08 01:02 peter-endian Status new => resolved
2009-12-08 01:02 peter-endian Fixed in Version => 2.3.1
2009-12-08 01:02 peter-endian Resolution open => fixed
2009-12-08 01:02 peter-endian Note Added: 0003524
2009-12-08 01:02 peter-endian Relationship added related to 0001532
2010-11-22 12:04 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker