SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000254: Status page always reports VPN (ipsec) at stopped - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000254Endian FirewallGUIpublic2007-08-31 22:152007-12-31 19:15
Reporterwheflin 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.1.2 
Target VersionFixed in Version2.2-beta2 
Summary0000254: Status page always reports VPN (ipsec) at stopped
DescriptionOn the "Status" page under the "Services" section the "VPN (ipsec)" service always shows "STOPPED" even though it is running. This has been broken in Endian for a very long time. Can someone please fix or advise what file(s) to edit so that it reports correctly?

Additional InformationI've looked through the /home/httpd/cgi-bin directory skimmed through the endianinc.pl, status.cgi, and vpnmain.cgi. I've also looked through the /var/efw/header.pl file and can't seem to pinpoint why this doesn't report the correct status of the service.

It appears to be trying to read the status of pluto.

When I run "ipsec pluto" manually it always reports:

pluto: lock file "/var/run/pluto/pluto.pid" already exists

(But then again I'm not sure if this is what tries to pull the status from or not)


TagsNo tags attached.
Attached Filesdiff file icon status.cgi.diff [^] (606 bytes) 2007-11-23 18:24 [Show Content]

- Relationships
duplicate of 0000295closedpeter-endian ipsec is always STOPPED within status.cgi 

-  Notes
(0000657)
the_dobc (reporter)
2007-11-23 18:25

chmod 0755 /var/run/pluto and apply patch to status.cgi
(0000665)
peter-endian (administrator)
2007-11-26 17:41

thank's the_dobc
your patch (reversed) made the trick!

- Issue History
Date Modified Username Field Change
2007-08-31 22:15 wheflin New Issue
2007-11-23 18:24 the_dobc File Added: status.cgi.diff
2007-11-23 18:25 the_dobc Note Added: 0000657
2007-11-23 19:26 peter-endian Relationship added duplicate of 0000295
2007-11-26 17:41 peter-endian Note Added: 0000665
2007-11-26 17:41 peter-endian Status new => resolved
2007-11-26 17:41 peter-endian Fixed in Version => 2.2
2007-11-26 17:41 peter-endian Resolution open => fixed
2007-11-26 17:41 peter-endian Assigned To => peter-endian
2007-12-31 19:15 raphael-endian Fixed in Version 2.2-beta1 => 2.2-beta2
2007-12-31 19:15 raphael-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker