SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002544: error while usb backupping - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002544Endian FirewallOther Scriptspublic2009-12-15 15:522010-11-22 12:06
Reporterluca-endian 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2 
Target Version2.3.1Fixed in Version2.3.1 
Summary0002544: error while usb backupping
DescriptionTried to run the /etc/cron.daily/usbbackup script

And it ends whit this:

Traceback (most recent call last):
  File "/usr/local/bin/efw-backupusb", line 313, in ?
    end_notifications()
  File "/usr/lib/python2.4/site-packages/endian/core/logger.py", line 59, in end_notifications
  File "/usr/lib/python2.4/site-packages/endian/core/notification.py", line 308, in end
  File "/usr/lib/python2.4/site-packages/endian/core/notification.py", line 242, in close
OSError: [Errno 2] No such file or directory: '/var/lock/services/backup.status'
Tagspurple
Attached Files

- Relationships
related to 0002646closedpeter-endian notifications: handle status of notifications file 

-  Notes
(0003716)
peter-endian (administrator)
2010-01-28 17:51

happens sometimes because end_notifications() will be called twice in some circumstances -> 0002544

and, always because:

efw-usbbackup calls backup-create.sh which both write within the same notifications file. backup-create.sh at the end removes that status file, bit efw-backupusb still needs it to write within it and at the end would like to remove it, but it has been already removed by backup-create.sh

backup-create.sh should not remove that file if exists on enable_notification()
in order to allow sort of cascading

- Issue History
Date Modified Username Field Change
2009-12-15 15:52 luca-endian New Issue
2009-12-15 15:53 luca-endian Tag Attached: purple
2009-12-15 15:54 luca-endian Description Updated
2010-01-21 19:04 peter-endian Assigned To => peter-endian
2010-01-21 19:04 peter-endian Status new => confirmed
2010-01-21 19:04 peter-endian Target Version => 2.3.1
2010-01-28 17:49 peter-endian Relationship added related to 0002646
2010-01-28 17:51 peter-endian Note Added: 0003716
2010-01-28 17:55 peter-endian Status confirmed => resolved
2010-01-28 17:55 peter-endian Fixed in Version => 2.3.1
2010-01-28 17:55 peter-endian Resolution open => fixed
2010-11-22 12:06 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker