SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002550: Message on the gui for a new kernel installed - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002550Endian FirewallOther Scriptspublic2009-12-16 14:102010-11-22 12:06
Reporterluca-endian 
Assigned Tosimon-endian 
PriorityhighSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3 
Target Version2.3.1Fixed in Version2.3.1 
Summary0002550: Message on the gui for a new kernel installed
DescriptionI've noticed that with the latest updates although a new kernel has been installed the user is not warned via gui that the system must be rebooted.

I remember it happened with 2.2
Tagspurple
Attached Files

- Relationships
parent of 0002660closed Kernel and Modules mismatch 
related to 0003355closedlorenzo-endian Reboot Required - Always on the dashboard 

-  Notes
(0003609)
peter-endian (administrator)
2009-12-19 04:11

This has not been implemented within dashboard!

Dashboard should also display such a message (like the old main.cgi did), if /var/tmp/oldkernel does exist.

Please discuss with christian for scheduling and GUI positioning
(0003610)
peter-endian (administrator)
2009-12-19 04:13

i think it's more or less important. Otherwise people do not reboot after 2.3 updates and that causes some iptables things misbehave

migration will reboot automatically
(0003697)
luca-endian (developer)
2010-01-25 08:48

If you don't reboot ipsec stop working because of a missing module:

FATAL: Could not load /lib/modules/2.6.22.19-72.e18/modules.dep No such file or directory
(0003723)
luca-endian (developer)
2010-01-29 10:26

I think this issue is also related to the kernel upgrade:

df -k
df: cannot read table of mounted filesystems: No such file or directory

It happened on two systems and after the reboot it was resolved.
(0003728)
peter-endian (administrator)
2010-02-01 16:51

df does not work anymore because the /etc/mtab link to /proc/mounts will be removed with the upgrade. the boot process creates a correct mtab file, so after reboot this is fixed.

it should not affect the kernel check script /usr/local/bin/checkkernel.sh, which understands if there was a kernel upgrade and creates a flag file in /var/tmp/oldkernel, if a reboot is necessary.

however, within the dashboard it's not implemented anymore to react upon that flag-file and display the boot message, so that's to fix whether upgrade does work or not.
(0003749)
luca-endian (developer)
2010-02-08 10:05

Feb 5 10:10:20 efw-1259685155 ipsec_setup: FATAL: Could not load /lib/modules/2.6.22.19-72.e18/modules.dep: No such file or directory
(0003754)
peter-endian (administrator)
2010-02-08 15:48

well ok.. this happens because a kernel upgrade need a reboot.
(0003778)
simon-endian (developer)
2010-02-15 04:06

now dashboard shows kernel version and instead of the version a "reboot required" message, if /var/tmp/oldkernel exists

- Issue History
Date Modified Username Field Change
2009-12-16 14:10 luca-endian New Issue
2009-12-19 04:11 peter-endian Note Added: 0003609
2009-12-19 04:11 peter-endian Assigned To => simon-endian
2009-12-19 04:11 peter-endian Status new => confirmed
2009-12-19 04:11 peter-endian Target Version => 2.3.1
2009-12-19 04:13 peter-endian Note Added: 0003610
2010-01-25 08:47 luca-endian Tag Attached: purple
2010-01-25 08:48 luca-endian Note Added: 0003697
2010-01-29 10:26 luca-endian Note Added: 0003723
2010-02-01 16:51 peter-endian Note Added: 0003728
2010-02-08 10:05 luca-endian Note Added: 0003749
2010-02-08 15:40 luca-endian Relationship added parent of 0002660
2010-02-08 15:48 peter-endian Note Added: 0003754
2010-02-10 10:38 luca-endian Priority normal => high
2010-02-15 04:06 simon-endian Note Added: 0003778
2010-02-15 04:06 simon-endian Status confirmed => resolved
2010-02-15 04:06 simon-endian Fixed in Version => 2.3.1
2010-02-15 04:06 simon-endian Resolution open => fixed
2010-11-22 12:06 peter-endian Status resolved => closed
2010-12-06 08:32 luca-endian Relationship added related to 0003355

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker