SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002574: no chance to start migration if we update only one version - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002574Endian FirewallMigrationpublic2009-12-19 02:452010-11-22 12:05
Reporterpeter-endian 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3 
Target Version2.3.1Fixed in Version2.3.1 
Summary0002574: no chance to start migration if we update only one version
Descriptionsince comparators always skip the migration if module version is <= current version
and if module version is >= new version, it's never possible to migrate
when new version is current version + 1
so module version needs to be current version or new version, but migration framework will never start with both possible cases.

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2009-12-19 02:45 peter-endian New Issue
2009-12-19 02:45 peter-endian Assigned To => peter-endian
2009-12-19 02:46 peter-endian Status new => resolved
2009-12-19 02:46 peter-endian Fixed in Version => 2.3.1
2009-12-19 02:46 peter-endian Resolution open => fixed
2010-11-22 12:05 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker