SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002585: collectd is eating all the memory - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002585Endian FirewallOther Servicespublic2009-12-29 08:092010-11-22 12:06
Reporteredwinhop 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3 
Target VersionFixed in Version2.3.1 
Summary0002585: collectd is eating all the memory
DescriptionThe process collectd is using a lot of memory in my 4Gb endian
resulting in higher loads and a not compleet dashboard.
Also the swap is completly used.

After reboot all is oke, but the collectd process is eating more and more
memory over day's




 
Additional Informationtop - 09:03:00 up 17 days, 19:06, 4 users, load average: 0.21, 0.30, 0.34
Tasks: 171 total, 4 running, 166 sleeping, 0 stopped, 1 zombie
Cpu(s): 4.2%us, 0.5%sy, 0.0%ni, 93.5%id, 1.7%wa, 0.0%hi, 0.2%si, 0.0%st
Mem: 3367312k total, 3242600k used, 124712k free, 15336k buffers
Swap: 530040k total, 525896k used, 4144k free, 81428k cached

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 1335 logsurfe 18 0 1796 620 248 R 7 0.0 1995:30 logsurfer
 5661 ntop 18 0 229m 45m 880 S 1 1.4 230:24.83 ntop
 1359 root 15 0 3552 2072 504 S 0 0.1 28:26.19 syslog-ng
 3455 root 15 0 2918m 2.3g 688 S 0 71.0 57:44.37 collectd
23822 squid 15 0 96900 67m 996 S 0 2.0 38:49.04 squid
    1 root 15 0 1512 132 60 S 0 0.0 0:14.83 init
    2 root 11 -5 0 0 0 S 0 0.0 0:00.00 kthreadd
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0003640)
peter-endian (administrator)
2010-01-04 16:55

this collectd version seems to have a memory leak. We are working on it

quick workaround is to make collectd restart every night. The workaround script is installed wrongly:

mv /etc/cron.daily/restartcollectd.sh /etc/cron.daily/restartcollectd

(0003653)
peter-endian (administrator)
2010-01-07 16:18

fixed cronscript for now (workaround)

- Issue History
Date Modified Username Field Change
2009-12-29 08:09 edwinhop New Issue
2010-01-04 16:52 peter-endian Relationship added duplicate of 0002566
2010-01-04 16:55 peter-endian Note Added: 0003640
2010-01-04 16:55 peter-endian Assigned To => peter-endian
2010-01-04 16:55 peter-endian Status new => confirmed
2010-01-07 16:18 peter-endian Note Added: 0003653
2010-01-07 16:18 peter-endian Status confirmed => resolved
2010-01-07 16:18 peter-endian Fixed in Version => 2.3.1
2010-01-07 16:18 peter-endian Resolution open => fixed
2010-11-22 12:06 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker