SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002702: Truncated and incorrect entries in content filter log (logs_dansguardian.cgi) - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002702Endian FirewallGUIpublic2010-02-19 10:442010-11-22 12:08
Reporterderyk 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3 
Target VersionFixed in Version2.4.1 
Summary0002702: Truncated and incorrect entries in content filter log (logs_dansguardian.cgi)
DescriptionWhen viewing /cgi-bin/logs_dansguardian.cgi the output comes out as follows (example line):

2010/Feb/01 08:53:02 192.168.0.2 (127.0.0.) http://news.google.co [^] ok

This is on the 19th of Feb, 08:53:20, from 192.168.0.23 to news.google.com - but each column is being truncated by 1 character. This also prevents it from correctly detecting the word "denied".

The correct output should be:

2010/Feb/19 08:53:20 192.168.0.23 (127.0.0.1) http://news.google.com [^] DENIED
Additional InformationTo fix the issue, go to line 164 of /home/httpd/cgi-bin/logs_dansguardian.cgi

Where it reads:
split(/[^,]\s+/, $line);

Change it to:
split(/\s+/, $line);
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0003821)
deryk (reporter)
2010-02-19 10:51
edited on: 2010-02-19 10:53

BTW I marked this as major because user of 192.168.0.2 (for example) could potentially face reprisal from their company for visiting a site that was actually visited by 192.168.0.23. This is my first bug report so correct me if this is the wrong way to evaluate it.

(0003934)
peter-endian (administrator)
2010-03-04 21:13

applied. thank you for the fix!

- Issue History
Date Modified Username Field Change
2010-02-19 10:44 deryk New Issue
2010-02-19 10:51 deryk Note Added: 0003821
2010-02-19 10:53 deryk Note Edited: 0003821
2010-03-04 21:13 peter-endian Note Added: 0003934
2010-03-04 21:13 peter-endian Status new => resolved
2010-03-04 21:13 peter-endian Fixed in Version => 2.3.1
2010-03-04 21:13 peter-endian Resolution open => fixed
2010-03-04 21:13 peter-endian Assigned To => peter-endian
2010-11-22 12:08 peter-endian Fixed in Version 2.3.1 => 2.4.1
2010-11-22 12:08 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker