SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002761: cleanup havp black/whitelist creation - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002761Endian FirewallProxy HTTPpublic2010-03-10 12:032010-11-22 12:08
Reporterpeter-endian 
Assigned Tosimon-endian 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version2.3.1Fixed in Version2.4.1 
Summary0002761: cleanup havp black/whitelist creation
DescriptionwriteHavpList() in restarthavp.py needs cleanup

it should:
1) check if /etc/havp/*list is a link, when it is -> remove it and touch the
   file with correct permissions
2) filecompare /var/efw/havp/*list with /etc/havp/*list, return function with
   False (changed == False) if it is same
3) if it differs, copy the content of /var/efw/havp/*list to /etc/havp/*list.
   dont use cat >>, which is appending and would cause to have a constantly
   growing file
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0004005)
peter-endian (administrator)
2010-03-10 12:04

right now we have the following errors:
cat: /etc/havp/whitelist: input file is output file
cat: /etc/havp/blacklist: input file is output file

because cat copies the content of the source file to a target file which is a link to the source file.
(0004033)
simon-endian (developer)
2010-03-15 16:37

efw-havp-2.3.19-0.endian3.i586.rpm

- Issue History
Date Modified Username Field Change
2010-03-10 12:03 peter-endian New Issue
2010-03-10 12:04 peter-endian Note Added: 0004005
2010-03-10 12:04 peter-endian Assigned To => simon-endian
2010-03-10 12:04 peter-endian Status new => assigned
2010-03-15 16:37 simon-endian Note Added: 0004033
2010-03-15 16:37 simon-endian Status assigned => resolved
2010-03-15 16:37 simon-endian Fixed in Version => 2.3.1
2010-03-15 16:37 simon-endian Resolution open => fixed
2010-11-22 12:08 peter-endian Fixed in Version 2.3.1 => 2.4.1
2010-11-22 12:08 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker