SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002792: user agent for opevpn through http proxy doesn't work - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002792Endian FirewallOpenVPN Client and Serverpublic2010-03-23 14:012010-11-22 12:08
Reporterluca-endian 
Assigned Tora-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3 
Target VersionFixed in Version2.4.1 
Summary0002792: user agent for opevpn through http proxy doesn't work
DescriptionWhen you encapsulate the vpn through a proxy http you may pretend to be a browser and you can force a fake user agent.

In gw2gw if you set the following field:
"Forge proxy user-agent"
the tunnel can't be established, this is due to a typo in the openvpnclient.conf.tmpl file.

Those are the lines:

#if $PROXY_VERSION != '':
http-proxy-option type VERSION $PROXY_VERSION
#end if

#if $PROXY_USERAGENT != '':
http-proxy-option type AGENT $PROXY_USERAGENT
#end if

They should be:

#if $PROXY_VERSION != '':
http-proxy-option VERSION $PROXY_VERSION
#end if

#if $PROXY_USERAGENT != '':
http-proxy-option AGENT $PROXY_USERAGENT
#end if

Without "type" because the type is already VERSION or AGENT, the man page is ambiguous on this option but I tried :)
Tagspurple
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2010-03-23 14:01 luca-endian New Issue
2010-03-23 14:02 luca-endian Tag Attached: purple
2010-03-25 15:54 ra-endian Assigned To => ra-endian
2010-03-25 15:54 ra-endian Status new => resolved
2010-03-25 15:54 ra-endian Resolution open => fixed
2010-11-22 12:08 peter-endian Fixed in Version => 2.4.1
2010-11-22 12:08 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker