SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002814: Error message using restartsmtpscan.py - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002814Endian FirewallProxy SMTPpublic2010-04-02 09:432010-11-22 11:51
Reporterbaldy 
Assigned Topeter-endian 
PrioritynormalSeveritytrivialReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3 
Target VersionFixed in Version2.4 
Summary0002814: Error message using restartsmtpscan.py
DescriptionOne of my clients has an EFW 2.3 system that had an entry for transparent source bypass, needed for their previous ISP which did not like the extra headers from spamassassin.
The transparent source entry was removed later on, due to the ISP change.

When using the restartsmtpscan.py script there is an error message :

2010-04-02 11:02:30,289 - restartsmtpscan.py[22694] - ERROR - Could not read byp
ass file '/var/efw/smtpscan/transparent_destination_bypass'!

The file mentioned does not exist, there is only a 0kb file transparent_source_bypass.

Removing this file also gets rid of the error.

Transparent_source_bypass is not removed when there are no entries, but left empty at 0kb, so the restartscript assumes there also should be a transparent_destination_bypass file.

When saving the configuration from the GUI there should be a check to see if the file is empty and if so the file should be deleted.

Regards,

Klaas-Jan
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0004108)
peter-endian (administrator)
2010-04-02 10:59

Does this cause any trouble, or print out just the error message?
(0004109)
baldy (reporter)
2010-04-02 14:01

Peter,

Just an error message, does not appear to cause a problem.

Regards,

Klaas-Jan
(0004140)
peter-endian (administrator)
2010-04-13 10:08

there's indeed a wrong check, so that if the source transparent file does exist, it is assumed that the destination file does also exist.

- Issue History
Date Modified Username Field Change
2010-04-02 09:43 baldy New Issue
2010-04-02 10:59 peter-endian Note Added: 0004108
2010-04-02 10:59 peter-endian Status new => feedback
2010-04-02 13:32 ra-endian Severity minor => trivial
2010-04-02 14:01 baldy Note Added: 0004109
2010-04-13 10:08 peter-endian Note Added: 0004140
2010-04-13 10:08 peter-endian Status feedback => confirmed
2010-04-13 10:11 peter-endian Status confirmed => resolved
2010-04-13 10:11 peter-endian Fixed in Version => codename: angry armadillo
2010-04-13 10:11 peter-endian Resolution open => fixed
2010-04-13 10:11 peter-endian Assigned To => peter-endian
2010-11-22 11:51 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker