SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000290: ftp proxy not working . - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000290Endian FirewallApplication Level Proxiespublic2007-11-02 07:052008-04-23 17:41
Reporterclubbing80s 
Assigned Tora-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta1 
Target Version2.2-beta4Fixed in Version2.2-beta4 
Summary0000290: ftp proxy not working .
DescriptionHi
The ftp proxy is not working correctly. I tested with firfox and ncftp.
When both are configured to use the proxy 21 the following error occurred
"501 Proxy unable to contact ftp server"
when both are configured to use the proxy 2121 the following error occurred
ff "reported 502 Command not implemented"
nctftp "Could not open host ftp.is.co.za: invalid reply from server.
        Could not read reply from control connection: Connection reset by peer"

I have attached frox.log for my testing period
TagsNo tags attached.
Attached Fileslog file icon frox.log [^] (37,723 bytes) 2007-11-02 07:05
? file icon frox.conf [^] (870 bytes) 2007-12-07 15:13
jpg file icon system_acess_4frox_conf.JPG [^] (80,814 bytes) 2007-12-07 15:16

- Relationships
has duplicate 0000538closedra-endian FTP Antivirus not working 
related to 0000262closedra-endian 421 Proxy tried to loop error when ftp proxy is enabled 

-  Notes
(0000684)
CIURI (reporter)
2007-12-06 19:58

Got the same problem but the log dosent tell me anything.Tried to recompile from scratch a version of frox no luck still not working.I think thats a bug from frox.I will try to run frox from other linux distro to see if its doing the same thing.
(0000685)
peter-endian (administrator)
2007-12-07 10:58

well, we try to eliminate frox and to use squid instead for ftp proxying
so far we have some troubles with some ftp authentication possibilities
(0000686)
CIURI (reporter)
2007-12-07 15:13

I got it working today ,first you must set from system access on the web interface
to let the traffic pass to the system and then the port 2121 opens and you are able to access frox.

The second problem is that the virus scan dosent work at all.All files are virus infected :).Thats stupid because I tried to scan with "/usr/bin/clamdscan" the file downloaded without the virus scan and the file is clean.The ftp link I tested is from hp.com where virus infected files cannot be :).

Whit out the virus scan option in the config file it works perfectly.

Only Firefox and Opera dosent like the ftp proxy.You will get timmed out when you try to download something from the ftp. Tried all configs possible whiteout
luck.In IE 7 it works whiteout problems.

I recompiled frox and activated the cache option and it works ok.
(0000694)
clubbing80s (reporter)
2007-12-12 09:30

Hi CIURI what source did you use to compile from ? a source rpm if so which one, or the raw source ?
Thanks for your input ..
(0000939)
ra-endian (administrator)
2008-02-28 14:47

the input firewall drops the connection to the frox.

Please change this line
from:
udp,,2121,on,,GREEN&BLUE&ORANGE&VPN:ANY,off,FTP,ACCEPT,,

to:
tcp,,2121,on,,GREEN&BLUE&ORANGE&VPN:ANY,off,FTP,ACCEPT,,

in the file /etc/firewall/inputfw/frox.conf.tmpl

and restart the frox with the command "restartfrox"
(0000981)
Anonymous (viewer)
2008-04-10 07:10
edited on: 2008-04-10 07:13

Hi,

changed the
from:
udp,,2121,on,,GREEN&BLUE&ORANGE&VPN:ANY,off,FTP,ACCEPT,,

to:
tcp,,2121,on,,GREEN&BLUE&ORANGE&VPN:ANY,off,FTP,ACCEPT,,

and on system access added a new rule

1 <ANY> GREEN BLUE TCP/2121 ALLOW FTPFROX
2 <ANY> GREEN BLUE TCP/21 ALLOW FTPFROX

Now i got no deny messages in firewall log.

Only
Apr 10 09:04:25 INPUTFW:ACCEPT:1 br0 KEY_TCP 192.168.x.x 1482 macaddress 172.16.x.30 2121

but i cant use an FTP Programm like Filezilla.. tryed Proxy 172.16.x.30 with ports 8080 , 2121 and 21.

Still no luck with FTP Transfer.

Endian Version is 2.2 beta 3.

I'm using the Endian in Gateway Mode.
Working as a Proxy, AV Filter and Content Filter.


- Issue History
Date Modified Username Field Change
2007-11-02 07:05 clubbing80s New Issue
2007-11-02 07:05 clubbing80s File Added: frox.log
2007-12-06 19:58 CIURI Note Added: 0000684
2007-12-07 10:58 peter-endian Note Added: 0000685
2007-12-07 15:13 CIURI Note Added: 0000686
2007-12-07 15:13 CIURI File Added: frox.conf
2007-12-07 15:16 CIURI File Added: system_acess_4frox_conf.JPG
2007-12-12 09:30 clubbing80s Note Added: 0000694
2008-02-04 14:42 ra-endian Relationship added has duplicate 0000538
2008-02-04 14:42 ra-endian Target Version => 2.2-rc1
2008-02-04 15:07 peter-endian Relationship added related to 0000262
2008-02-28 14:31 ra-endian Status new => assigned
2008-02-28 14:31 ra-endian Assigned To => ra-endian
2008-02-28 14:31 ra-endian Status assigned => confirmed
2008-02-28 14:47 ra-endian Status confirmed => resolved
2008-02-28 14:47 ra-endian Fixed in Version => 2.2-rc1
2008-02-28 14:47 ra-endian Resolution open => fixed
2008-02-28 14:47 ra-endian Note Added: 0000939
2008-03-04 14:42 ra-endian Target Version 2.2-rc1 => 2.2-beta4
2008-03-04 14:43 ra-endian Fixed in Version 2.2-rc1 => 2.2-beta4
2008-04-10 07:10 Anonymous Status resolved => feedback
2008-04-10 07:10 Anonymous Resolution fixed => reopened
2008-04-10 07:10 Anonymous Note Added: 0000981
2008-04-10 07:11 Anonymous Note Edited: 0000981
2008-04-10 07:13 Anonymous Note Edited: 0000981
2008-04-22 13:25 ra-endian Status feedback => resolved
2008-04-22 13:25 ra-endian Resolution reopened => fixed
2008-04-23 17:41 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker