SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002915: dnsmasq blocking cron - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002915Endian FirewallApplication Level Proxiespublic2010-05-24 13:342011-08-31 14:37
Reporteralbaney 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityrandom
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3 
Target Version2.4.1Fixed in Version2.3 
Summary0002915: dnsmasq blocking cron
DescriptionThe script getblackholedns.py sometimes became "defunct" and block the cron.daily (if the option "Spyware domain list update schedule" is mark for daily)
Additional InformationThe log /var/log/messages presents the following line on this error:

May 24 01:25:00 efwedu fcron[4163]: process already running: root's [ -x /bin/run-parts ] && run-parts --report /etc/cron.daily

I have 3 endians and the same error occurs in everyone, but in random way: one day a endian stops run the cron.daily, another day other machine stops.
Tagspurple
Attached Files

- Relationships
related to 0003002feedbackpeter-endian Daily Backup doesn´t work 
child of 0003044confirmedpeter-endian TODO: check all cron scripts that they redirect stdout/stderr in order to prevent zombies 

-  Notes
(0004516)
luca-endian (developer)
2010-06-15 09:56

blackholedns became zombie

root@efw:/etc/cron.daily # zcat /var/log/messages-20100614.gz | grep cron.daily
Jun 14 01:25:00 efw fcron[6151]: process already running: root's [ -x /bin/run-parts ] && run-parts --report /etc/cron.daily

?fcron,6151 -c /etc/fcron.conf
  ? ??fcron,14763 -c /etc/fcron.conf
  ? ??bash,14764 -c [\040-x\040/bin/run-parts\040]\040&&\040run-parts\040--report\040/etc/cron.daily
  ? ??run-parts,14765 --report /etc/cron.daily
  ? ??(blackholedns,15219)
(0004517)
peter-endian (administrator)
2010-06-15 10:02

can you try to replace the following line:

/usr/local/bin/getblackholedns.py &

with

/usr/local/bin/getblackholedns.py &>/dev/null &

in /usr/lib/dnsmasq/blackholedns.cron

this should stop the script becoming a zombie.
(0004826)
peter-endian (administrator)
2010-09-23 11:00

this does not seem to fix the problem. see 0003002
(0004876)
peter-endian (administrator)
2010-09-24 16:42

found getblackholedns script hanging for days.. if it is detached there are now a couple of getblackholedns processes.

seems that script has a problem.
(0004917)
peter-endian (administrator)
2010-10-06 15:49

made some changes in getblackhole script, now it is not hanging anymore
(0004918)
peter-endian (administrator)
2010-10-06 15:51

happened again :(
(0004921)
peter-endian (administrator)
2010-10-07 09:55

getblackholedns.py keeps running because the http connection will not be closed.
it is open now for more than a day and in CLOSE_WAIT state:

getblackh 30303 root 3u IPv4 2725624 TCP 10.7.5.200:37102->malwaredomains.riskanalytics.com:http (CLOSE_WAIT)
getblackh 30303 root 6u IPv4 2725627 TCP 10.7.5.200:37103->malwaredomains.riskanalytics.com:http (ESTABLISHED)

no wonder that malwaredomains.com has a high load on their server :/
(0004922)
peter-endian (administrator)
2010-10-07 10:21

added a close() after reading etag header. but i'm not sure if this fixes the problem since can't reproduce the problem while debugging
trying to let it run a while with the added close()
(0005473)
peter-endian (administrator)
2011-01-12 13:38

problem might be an overflowing buffer:

-----------8<--------------------------
   htmlFile = __urllib2.urlopen(request)
   htmlData = htmlFile.read()
   htmlFile.close()
-----------8<--------------------------

htmlData should hold the entire file to be downloaded.. maybe that becomes a little bit huge if the file is big.

download_file() should produce an interator which can be used in order to write down each single line to the file using download_file_to()

- Issue History
Date Modified Username Field Change
2010-05-24 13:34 albaney New Issue
2010-06-07 10:32 peter-endian Status new => acknowledged
2010-06-07 10:32 peter-endian Target Version => future
2010-06-15 09:56 luca-endian Note Added: 0004516
2010-06-15 09:56 luca-endian Tag Attached: purple
2010-06-15 10:00 peter-endian Assigned To => peter-endian
2010-06-15 10:00 peter-endian Status acknowledged => confirmed
2010-06-15 10:00 peter-endian Target Version future => 2.4
2010-06-15 10:02 peter-endian Note Added: 0004517
2010-06-21 14:53 luca-endian Relationship added parent of 0003002
2010-07-03 19:23 sawilla Note Added: 0004581
2010-07-03 19:29 sawilla Note Deleted: 0004581
2010-07-05 16:20 peter-endian Relationship replaced related to 0003002
2010-07-05 16:23 peter-endian Issue cloned: 0003044
2010-07-05 16:23 peter-endian Relationship added child of 0003044
2010-07-05 16:23 peter-endian Status confirmed => resolved
2010-07-05 16:23 peter-endian Fixed in Version => 2.4
2010-07-05 16:23 peter-endian Resolution open => fixed
2010-09-23 11:00 peter-endian Note Added: 0004826
2010-09-23 11:00 peter-endian Status resolved => acknowledged
2010-09-23 11:00 peter-endian Target Version 2.4 => 2.4.1
2010-09-24 16:05 peter-endian Status acknowledged => assigned
2010-09-24 16:42 peter-endian Note Added: 0004876
2010-10-06 15:49 peter-endian Note Added: 0004917
2010-10-06 15:49 peter-endian Status assigned => resolved
2010-10-06 15:51 peter-endian Note Added: 0004918
2010-10-06 15:51 peter-endian Status resolved => confirmed
2010-10-06 15:52 peter-endian Status confirmed => assigned
2010-10-07 09:55 peter-endian Note Added: 0004921
2010-10-07 10:21 peter-endian Note Added: 0004922
2011-01-12 13:38 peter-endian Note Added: 0005473
2011-01-17 14:18 peter-endian Status assigned => resolved
2011-01-17 14:18 peter-endian Customer Occurencies => 0
2011-01-17 14:18 peter-endian Fixed in Version 2.4 => 2.5
2011-08-31 14:37 lorenzo-endian Status resolved => closed
2011-08-31 14:37 lorenzo-endian Fixed in Version 2.5 => 2.3

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker