SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000293: Netwizard writes down NETMASK in CIDR notation - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000293Endian FirewallInstallationpublic2007-11-03 15:402007-12-31 19:11
Reporterpeter-endian 
Assigned Topeter-endian 
PriorityimmediateSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta1 
Target VersionFixed in Version2.2-beta2 
Summary0000293: Netwizard writes down NETMASK in CIDR notation
DescriptionNetwizard always writes down the *_NETMASK variables in CIDR notation (24), which leads into disfunctional services.

OpenVPN, DHCP, and maybe also others will not start, because they need bitmask notation (255.255.255.0).

Workaround:
Edit /var/efw/ethernet/settings and replace the values of _NETMASK with the corresponding bitmask notation. For example 24 -> 255.255.255.0
TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0000362closedpeter-endian DHCP failure 
related to 0000279closedpeter-endian DHCP doesn't work on EFW 2.2 Beta1 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2007-11-03 15:40 peter-endian New Issue
2007-11-03 15:41 peter-endian Assigned To => peter-endian
2007-11-03 15:41 peter-endian Priority normal => urgent
2007-11-03 15:41 peter-endian Severity minor => crash
2007-11-03 15:41 peter-endian Status new => confirmed
2007-11-03 15:41 peter-endian Resolution open => reopened
2007-11-03 15:42 peter-endian Relationship added related to 0000279
2007-11-07 14:59 ra-endian Priority urgent => immediate
2007-11-07 16:02 peter-endian Status confirmed => resolved
2007-11-07 16:02 peter-endian Fixed in Version => 2.2
2007-11-07 16:02 peter-endian Resolution reopened => fixed
2007-12-10 16:52 peter-endian Relationship added has duplicate 0000362
2007-12-31 15:05 raphael-endian Fixed in Version 2.2-beta1 => 2.2-beta2
2007-12-31 19:11 raphael-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker