SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002943: After upgrade 2.3 to 2.4 , network statistics are not displayed - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002943Endian FirewallGUIpublic2010-05-28 20:082010-07-23 03:52
Reporterleso 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusfeedbackResolutionreopened 
PlatformOSOS Version
Product Version2.4 
Target Version2.4Fixed in Version2.4 
Summary0002943: After upgrade 2.3 to 2.4 , network statistics are not displayed
DescriptionAfter a upgrade of 2.3 to a 2.4 , with efw-upgrade (community version) the old statistics on network traffic graphs aren't displayed. The new graphs (new statistics) are also not appear.

thx
KR
Additional InformationOn 2.3 production , graphs was always displayed.
TagsNo tags attached.
Attached Files? file icon libipt_standard.so [^] (3,608 bytes) 2010-07-05 06:12

- Relationships
related to 0002897closedpeter-endian Couldn't load target `standard':/lib/iptables/libipt_standard.so: cannot open shared object file: No such file or directory 
has duplicate 0003020closed Traffic Graphs - Endian Firewall Community version 2.4 
has duplicate 0003200closed Traffic Graphs not showing 

-  Notes
(0004298)
Renee (reporter)
2010-05-29 00:54

I can confirm this no network traffic graph is displayed.
(0004300)
baldy (reporter)
2010-05-29 08:22
edited on: 2010-05-30 09:11

I have the same problem.

Happens both in Internet Explorer 8 and Firefox 3.6.

(0004301)
albaney (reporter)
2010-05-29 12:32

The same occurs in a new installation. The network graph is not displayed.
(0004302)
Renee (reporter)
2010-05-29 12:40
edited on: 2010-05-29 15:29

It could be due with that the firewall.log not exist that the next problem no iptables log write down in /var/log.

I also checked the Proxy diagramms under status the same problem no information available.

(0004305)
leso (reporter)
2010-05-30 08:41

NOTE: With a new installation, it's the same problem.
(0004321)
schraads (reporter)
2010-05-31 19:48

I did a fresh install of 2.4.0 community edition and I am seeing the same thing. System graphs work, but no traffic graphs. I have verified this with IE 8, Firefox 3.6.3, and Google Chrome 5.0.
(0004322)
schraads (reporter)
2010-05-31 19:52
edited on: 2010-06-05 05:48

FYI...the real-time network graphs (on the Dashboard) for each interface ARE working on the home page.

(0004343)
omriasta (reporter)
2010-06-02 18:25
edited on: 2010-06-02 18:38

Using Chrome 6.0 (dev) on Ubuntu I can't view the real-time network graphs on the dashboard. Using Firefox 3.6.3 the real-time graphs do display on dashboard.
The graphs under Status->Traffic Graphs don't display in both browsers.
Update: Clear Cache solves problem in Chrome. Status Graphs still don't work.

(0004356)
schraads (reporter)
2010-06-05 05:50

I also cleared my cache and I am still not seeing any network traffic graphs. The system graphs are working.
(0004464)
peter-endian (administrator)
2010-06-09 17:56

this happens because ipac-ng did not work anymore with iptables 1.4.0
upgraded both ipac-ng and iptables in order to synchronize the library interface and fixed regexp in makegraphs which reads out data from ipac-ng output, since that output has now capitalized letters and makegraphs regexp was not case insensitive
(0004538)
bnhansen (reporter)
2010-06-17 20:55

I again upgraded my 2.4 version which has been running for a few weeks after seeing that the administrator had performed upgrades. After performing another upgrade today & rebooting, I also still do not display the status network traffic graphs or the status proxy access graphs. Where the graphs should be it states No Information Available.
(0004539)
Renee (reporter)
2010-06-17 21:47

Same problem again I must installed the endian new during a fatal error of me and the graph show nothing althought the endian is over efw-upgrade on the newest stand.On an other Endian 2.4 installation with the same updates it works.
I checked for the file /lib/iptables/libipt_standard.so the file does not exist on both systems.
(0004580)
devorem (reporter)
2010-07-03 00:43

I have this same problem on a new installation. Is there a procedure to edit the code and make this work?
(0004583)
leso (reporter)
2010-07-05 06:12

I copy the libipt_standard.so from a 2.3 to a 2.4 with all upgrades. One reboot later and one day later , I have actually my graph network traffic view...
I predict it just a file missing on package.
(0004584)
leso (reporter)
2010-07-05 06:12

I added file from 2.3 on this topic
(0004585)
leso (reporter)
2010-07-05 06:26

Actually , there is a problem with Live log viewer, the ports are in hexa? :

INPUT:DROP eth1 (eth1) 93.186.25.33: -> 188.62.81.246:00:0c:29:2e:de:89:00:07:cb:c5:b9:2f:08:00-
(0004640)
Fungyo (reporter)
2010-07-23 03:52

copying the attached file into the correct directory has enabled Network graphs for my install.
Install is fully updated too.

- Issue History
Date Modified Username Field Change
2010-05-28 20:08 leso New Issue
2010-05-29 00:54 Renee Note Added: 0004298
2010-05-29 08:22 baldy Note Added: 0004300
2010-05-29 12:32 albaney Note Added: 0004301
2010-05-29 12:40 Renee Note Added: 0004302
2010-05-29 15:29 Renee Note Edited: 0004302
2010-05-30 08:41 leso Note Added: 0004305
2010-05-30 09:11 baldy Note Edited: 0004300
2010-05-31 19:48 schraads Note Added: 0004321
2010-05-31 19:52 schraads Note Added: 0004322
2010-06-02 18:25 omriasta Note Added: 0004343
2010-06-02 18:38 omriasta Note Edited: 0004343
2010-06-05 05:48 schraads Note Edited: 0004322
2010-06-05 05:50 schraads Note Added: 0004356
2010-06-07 08:22 peter-endian Status new => confirmed
2010-06-07 13:05 peter-endian Relationship added related to 0002897
2010-06-07 14:14 peter-endian Target Version => 2.4
2010-06-07 14:21 peter-endian Status confirmed => assigned
2010-06-07 14:21 peter-endian Status assigned => new
2010-06-07 14:21 peter-endian Assigned To => peter-endian
2010-06-07 14:22 peter-endian Status new => assigned
2010-06-09 17:56 peter-endian Note Added: 0004464
2010-06-09 17:56 peter-endian Status assigned => resolved
2010-06-09 17:56 peter-endian Fixed in Version => 2.4
2010-06-09 17:56 peter-endian Resolution open => fixed
2010-06-17 20:47 Anonymous Note Added: 0004537
2010-06-17 20:47 Anonymous Status resolved => feedback
2010-06-17 20:47 Anonymous Resolution fixed => reopened
2010-06-17 20:55 bnhansen Note Added: 0004538
2010-06-17 20:55 Anonymous Note Edited: 0004537
2010-06-17 20:57 Anonymous Note Edited: 0004537
2010-06-17 21:05 Anonymous Note Edited: 0004537
2010-06-17 21:47 Renee Note Added: 0004539
2010-06-21 13:34 peter-endian Relationship added has duplicate 0003020
2010-06-22 08:29 Anonymous Note Edited: 0004537
2010-06-30 09:48 Anonymous Note Edited: 0004537
2010-07-03 00:43 devorem Note Added: 0004580
2010-07-05 06:12 leso Note Added: 0004583
2010-07-05 06:12 leso File Added: libipt_standard.so
2010-07-05 06:12 leso Note Added: 0004584
2010-07-05 06:26 leso Note Added: 0004585
2010-07-07 21:04 Anonymous Note Edited: 0004537
2010-07-23 03:52 Fungyo Note Added: 0004640
2010-07-27 23:01 Anonymous Note Edited: 0004537
2010-08-19 09:54 Anonymous Note Deleted: 0004537
2010-10-25 15:01 peter-endian Relationship added has duplicate 0003200

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker