SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002957: Map network with SNAT has wrong input checks - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002957Endian FirewallFirewall (iptables)public2010-05-31 14:232010-11-22 11:49
Reporterluca-endian 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3.1 
Target Version2.4Fixed in Version2.4 
Summary0002957: Map network with SNAT has wrong input checks
DescriptionWhile crating a SNAT rule to map a network destination subnet is checked instead of source (it's the same check of the DNAT rule).

If you want to map a local network with SNAT and translate to a private subnet like this:

Source: 172.16.0.0/26
Destination: any uplink or a specific uplink
Map to subnet: 74.x.x.0/26

You get an error: "Destination must be a subnet!"

That's wrong because Source should be a subnet.
Tagspurple
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2010-05-31 14:23 luca-endian New Issue
2010-05-31 14:23 luca-endian Tag Attached: purple
2010-06-07 09:17 peter-endian Status new => confirmed
2010-06-07 14:14 peter-endian Target Version => 2.4
2010-06-07 14:21 peter-endian Status confirmed => assigned
2010-06-07 14:21 peter-endian Status assigned => new
2010-06-07 14:21 peter-endian Assigned To => peter-endian
2010-06-07 14:22 peter-endian Status new => assigned
2010-06-08 09:40 peter-endian Status assigned => resolved
2010-06-08 09:40 peter-endian Fixed in Version => 2.4
2010-06-08 09:40 peter-endian Resolution open => fixed
2010-11-22 11:49 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker