SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002970: SMTP Proxy: "Bad sender address syntax" - admin notification fails - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002970Endian FirewallProxy SMTPpublic2010-06-03 10:262010-11-22 11:49
ReporterOrbitseeker 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.4 
Target Version2.4Fixed in Version2.4 
Summary0002970: SMTP Proxy: "Bad sender address syntax" - admin notification fails
DescriptionThe admin notification for spam and virus mails fails. The issue is caused by a bug in amavisd-new-2.6.2-0.endian22

SMTP Proxy log:

amavis[20034]: (20034-02) (!)FAILED to notify admin: 501 5.1.7 Failed, id=20034-02, from MTA([127.0.0.1]:10025): 501 5.1.7 Bad sender address syntax

amavis[20034]: (20034-02) (!)SEND via SMTP: postmaster@<HOSTNAME.DOMAIN> -> ,ENVID=AM..20100602T231523Z@<HOSTNAME.DOMAIN> 501 5.1.7 Failed, id=20034-02, from MTA([127.0.0.1]:10025): 501 5.1.7 Bad sender address syntax
Additional InformationThe following patches solved the issue:

amavisd.2.6.2.patch4:
http://mirrors.catpipe.net/amavisd-new/hgweb/amavis/rev/7f8be5ae184f [^]

amavisd.2.6.2.patch6:
http://mirrors.catpipe.net/amavisd-new/hgweb/amavis/rev/5b06eb41f689 [^]

Further testing ongoing.
TagsNo tags attached.
Attached Filestxt file icon amavisd.2.6.2.patch4.txt [^] (813 bytes) 2010-06-03 10:26 [Show Content]
txt file icon amavisd.2.6.2.patch6.txt [^] (839 bytes) 2010-06-03 10:26 [Show Content]

- Relationships

-  Notes
(0004423)
peter-endian (administrator)
2010-06-08 08:54

applied

thank you for the patches!

- Issue History
Date Modified Username Field Change
2010-06-03 10:26 Orbitseeker New Issue
2010-06-03 10:26 Orbitseeker File Added: amavisd.2.6.2.patch4.txt
2010-06-03 10:26 Orbitseeker File Added: amavisd.2.6.2.patch6.txt
2010-06-07 08:28 peter-endian Status new => confirmed
2010-06-07 14:14 peter-endian Target Version => 2.4
2010-06-07 14:21 peter-endian Status confirmed => assigned
2010-06-07 14:21 peter-endian Status assigned => new
2010-06-07 14:21 peter-endian Assigned To => peter-endian
2010-06-07 14:22 peter-endian Status new => assigned
2010-06-08 08:54 peter-endian Note Added: 0004423
2010-06-08 08:54 peter-endian Status assigned => resolved
2010-06-08 08:54 peter-endian Fixed in Version => 2.4
2010-06-08 08:54 peter-endian Resolution open => fixed
2010-11-22 11:49 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker