SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002979: Web Server in Green not allows port forward - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002979Endian FirewallFirewall (iptables)public2010-06-05 01:112010-09-23 14:06
ReporterPablitus 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusfeedbackResolutionopen 
PlatformOSOS Version
Product Version2.4 
Target VersionFixed in Version 
Summary0002979: Web Server in Green not allows port forward
DescriptionHey Boys!

I'm trying to setup a WEB server (TCP port 80) on the GREEN interface side.
I setup a Port forwarding / NAT rule to redirect all packets from main uplink port 80 and destination TCP port 80 to my server. But it´s not working...i have a time out.

If i try directly to Web server IP in the Green zone, everything works....so web server is working fine. The problem is when I try to use the NAT tranlation. What i am missing? I attach a picture of the NAT config.

I comes from IPCop and with the port forward is enough, but maybe i need some additional steps here

Any help would be appreciated

Thanks!
TagsNo tags attached.
Attached Filesjpg file icon Endian.jpg [^] (51,600 bytes) 2010-06-05 01:11


jpg file icon port forward.jpg [^] (161,482 bytes) 2010-06-05 14:33


jpg file icon Endian1.jpg [^] (59,741 bytes) 2010-06-05 21:39

- Relationships

-  Notes
(0004359)
baldy (reporter)
2010-06-05 13:55

Looks like you made an error in the portnumber.

It says 8000 instead of 80
(0004360)
Pablitus (reporter)
2010-06-05 14:21

Sorry....i tried both ports, 80 and 8000....both without luck.

Thanks
(0004361)
baldy (reporter)
2010-06-05 14:33

Pablitus,

Added image with correct settings.

Might be useful to continue in the supportforums as this is most likely not a bug.

http://www.endian.com/en/community/get-help/ [^]

Regards,

Klaas-Jan
(0004364)
Pablitus (reporter)
2010-06-05 21:40

It still not working, i used your settings without luck. I am uploading the settings that i´m using.

What i'm missing? The rest of the firewall works fine, even port forward for torrents.
(0004365)
baldy (reporter)
2010-06-06 09:18

Maybe stupid question, are you testing the forward from an external location or from a pc connected to green ?
(0004417)
Pablitus (reporter)
2010-06-07 16:00

I tested from both sides and it didn't work until today... but today morning i do a full reboot of the Endian and Webserver and started to work fine, weird...

Now i can see the server from the internet and from the green interface (but in the pc of the green side i need to hit via IP not by dns name because in that way it gives me a time out) So i think we are good to go...

Thanks
(0004447)
motionmedia (reporter)
2010-06-09 06:13

I can confirm the exact same problem with 2.4. Port forwarding simply does not work on port 80 or any other I try.

I have followed directions online, done as above, and nothing will go through. No mention of the attempts in the Endian logs, either.

I have tried re-booting, resetting the entire network, but to no avail. Port forwarding simply does not work.

Running community edition 10.4 on a dell with 2 dlink NIC cards and the built in LAN port. Have tried switching red/green interfaces around as well but to no avail.

I'm interested in helping to diagnose this problem so if you require any further info please let me know.
(0004841)
peter-endian (administrator)
2010-09-23 14:06

does the server in green have configured a correct default gateway pointing to the green ip of the firewall?

- Issue History
Date Modified Username Field Change
2010-06-05 01:11 Pablitus New Issue
2010-06-05 01:11 Pablitus File Added: Endian.jpg
2010-06-05 13:55 baldy Note Added: 0004359
2010-06-05 14:21 Pablitus Note Added: 0004360
2010-06-05 14:33 baldy Note Added: 0004361
2010-06-05 14:33 baldy File Added: port forward.jpg
2010-06-05 21:31 Anonymous Note Added: 0004363
2010-06-05 21:31 Anonymous Status new => feedback
2010-06-05 21:38 Anonymous Note Deleted: 0004363
2010-06-05 21:39 Pablitus File Added: Endian1.jpg
2010-06-05 21:40 Pablitus Note Added: 0004364
2010-06-06 09:18 baldy Note Added: 0004365
2010-06-07 16:00 Pablitus Note Added: 0004417
2010-06-09 06:13 motionmedia Note Added: 0004447
2010-09-23 14:06 peter-endian Note Added: 0004841

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker