SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0002993: Problem with Openvpn and capital letters - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002993Endian FirewallOpenVPN Client and Serverpublic2010-06-10 12:362010-11-22 11:49
Reporterluca-endian 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3.1 
Target Version2.4Fixed in Version2.4 
Summary0002993: Problem with Openvpn and capital letters
Descriptionwe found a script error in the Openvpnclient:
 >
 > The EFW translated automatically the OpenVPN Client "Connection name"
 > in small type, example:
 > Connection name = vpnCONACTIVE
 > EFW translated automatically = vpnconactive
 >
 > He creates a file /var/efw/openvpnclients/vpnconactive/data.
 > But one Script looks in /vpnCONACTIVE, see OpenVPN Log
 >
 > OpenVPN Log:
 >
-------------------------------------------------------------------------------------------------
 > Jun 7 15:09:17 efw8 vpnconactive[9895]: Traceback (most recent call
 > last):
 > Jun 7 15:09:17 efw8 vpnconactive[9895]: File
 > "/usr/local/bin/openvpnbridge.py", line 310, in ?
 > Jun 7 15:09:17 efw8 vpnconactive[9895]:
 > setLiveData(config_value['NAME'])
 > Jun 7 15:09:17 efw8 vpnconactive[9895]: File
 > "/usr/local/bin/openvpnbridge.py", line 169, in setLiveData
 > Jun 7 15:09:17 efw8 vpnconactive[9895]: d.write()
 > Jun 7 15:09:17 efw8 vpnconactive[9895]: File
 > "/usr/lib/python2.4/site-packages/endian/data/container/settings.py",
 > line 331, in write
 > Jun 7 15:09:17 efw8 vpnconactive[9895]: File
 > "/usr/lib/python2.4/site-packages/endian/core/filetools.py", line 18,
 > in openLocking
 > Jun 7 15:09:17 efw8 vpnconactive[9895]: IOError: [Errno 2] No such
 > file or directory: '/var/efw/openvpnclients//vpnCONACTIVE/data'
 > Jun 7 15:09:17 efw8 vpnconactive[9895]: run-parts:
 > /etc/openvpn/ifup.client.d//00bridge exited with return code 1
 > Jun 7 15:09:21 efw8 vpnconactive[9895]: Mon Jun 7 15:09:21 2010
 > Initialization Sequence Completed
 >
-------------------------------------------------------------------------------------------------
 >
 > Make an OpenVPN Client connection with "Connetion name" = vpnENDIAN
 > and now you get the error in the OpenVPN Log
 >
 >
 > Next point:
 > The Gw2Gw Password is stored in plain text:>(
 > /var/efw/openvpnclients/vpnconactive/credentials
Tagspurple
Attached Files

- Relationships

-  Notes
(0004471)
peter-endian (administrator)
2010-06-10 13:47

will fix the problem with capital letters

there is however no chance to store the password encrypted, since the client needs it in plaintext.

- Issue History
Date Modified Username Field Change
2010-06-10 12:36 luca-endian New Issue
2010-06-10 12:36 luca-endian Tag Attached: purple
2010-06-10 13:45 peter-endian Assigned To => peter-endian
2010-06-10 13:45 peter-endian Status new => assigned
2010-06-10 13:47 peter-endian Note Added: 0004471
2010-06-11 11:18 peter-endian Target Version => 2.4
2010-06-14 10:52 peter-endian Status assigned => resolved
2010-06-14 10:52 peter-endian Fixed in Version => 2.4
2010-06-14 10:52 peter-endian Resolution open => fixed
2010-11-22 11:49 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker