SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0003029: After starting Snort empty config page - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003029Endian FirewallGUIpublic2010-06-25 21:172010-11-22 11:51
Reportermschwenk 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.4 
Target VersionFixed in Version2.4.1 
Summary0003029: After starting Snort empty config page
DescriptionI installed new endian community 2.4

I updated snortrules and started snort. Now the mainpage of snort is just empty. (see atached pic)

/usr/local/bin/restartsnortrules.py worked but didnĀ“t change anything

/usr/local/bin/restartsnort.py gave me following error:
snort (pid 8695 8692) is running...
Stopping snort: [ OK ]
snort is stopped
2010-06-25 23:04:17,067 - restartsnort.py/enabled_rule_targets[8650] - INFO - Starting SNORT...
Starting snort: [ OK ]
Traceback (most recent call last):
  File "/usr/local/bin/restartsnort.py", line 401, in ?
    exit(0)
  File "/usr/local/bin/restartsnort.py", line 58, in exit
    end_notifications()
  File "/usr/lib/python2.4/site-packages/endian/core/logger.py", line 140, in end_notifications
  File "/usr/lib/python2.4/site-packages/endian/core/logger.py", line 266, in end_notifications
  File "/usr/lib/python2.4/site-packages/endian/core/notification.py", line 312, in end
  File "/usr/lib/python2.4/site-packages/endian/core/notification.py", line 238, in close
OSError: [Errno 2] No such file or directory: '/var/lock/services/snort.status'


I created /var/lock/services/snort.status with touch

Now the script worked but gui ist still broken. If i remove whole Folder /etc/snort the gui is there again but then it is not working because of missing configfiles.

I reinstalled and had the same error again.

Can you give me any advices? In generel Snort seems to run but is not accessable via gui.

Best regards

Mario
TagsNo tags attached.
Attached Filesjpg file icon Unbenannt.JPG [^] (134,144 bytes) 2010-06-25 21:17

- Relationships

-  Notes
(0004789)
peter-endian (administrator)
2010-09-21 13:54

can you check in /var/log/httpd/error_log
you should find there some error messages about this issue
(0004923)
peter-endian (administrator)
2010-10-07 13:56

fixed it.. here is a patch:

----------------------------------------------------------------------
Index: ids.cgi
===================================================================
--- ids.cgi (revision 23991)
+++ ids.cgi (working copy)
@@ -245,14 +245,14 @@
     if (-e $conffile) {
         readhash($conffile, \%timeconf);
     }
- if ($conf->{'TIMEZONE'} =~ /^$/) {
+ if ($timeconf{'TIMEZONE'} =~ /^$/) {
         my %mainhash = ();
         my $mainconf = \%mainhash;
         readhash($mainsettings, $mainconf);
- $conf->{'TIMEZONE'} = $mainconf->{'TIMEZONE'};
- $conf->{'TIMEZONE'} =~ s+/usr/share/zoneinfo/(posix/)?++;
+ $timeconf{'TIMEZONE'} = $mainconf->{'TIMEZONE'};
+ $timeconf{'TIMEZONE'} =~ s+/usr/share/zoneinfo/(posix/)?++;
     }
- my $tz = DateTime::TimeZone->new( name => $conf->{'TIMEZONE'} );
+ my $tz = DateTime::TimeZone->new( name => $timeconf{'TIMEZONE'} );
     $dt->set_time_zone($tz);
     return $dt->strftime("%d.%m.%Y, %H:%M:%S");
 }
----------------------------------------------------------------------

- Issue History
Date Modified Username Field Change
2010-06-25 21:17 mschwenk New Issue
2010-06-25 21:17 mschwenk File Added: Unbenannt.JPG
2010-09-21 13:54 peter-endian Note Added: 0004789
2010-09-21 13:54 peter-endian Status new => feedback
2010-10-07 13:55 peter-endian Assigned To => peter-endian
2010-10-07 13:55 peter-endian Status feedback => confirmed
2010-10-07 13:56 peter-endian Note Added: 0004923
2010-10-07 13:56 peter-endian Status confirmed => resolved
2010-10-07 13:56 peter-endian Fixed in Version => 2.4.1
2010-10-07 13:56 peter-endian Resolution open => fixed
2010-11-22 11:51 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker