SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0003053: Problems when editing or adding hosts - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003053Endian FirewallNetwork related (VPN, uplinks)public2010-07-06 18:542010-11-22 12:08
ReporterMo_Hong 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.4 
Target VersionFixed in Version2.4.1 
Summary0003053: Problems when editing or adding hosts
DescriptionAfter upgrading from 2.2 and 2.3 to 2.4, we detected that when you tried to edit or add a host in Network -> Edit Hosts, the system lets you input the information for the host, or edit the information, but after you press "update", the hosts table looses the IP information of all hosts. Example:

1. Original Table

    IP Hostname Domain
192.168.0.1 example domain.com

After pressing "update"

2. Table looses information

    IP Hostname Domain
   example domain.com

We have already tried in two different installs, one upgraded from 2.2 to 2.4 and the second one from 2.3 to 2.4
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0004602)
_thebishop_ (reporter)
2010-07-07 14:27

I confirm this behaviour also on my 2 EFWs (Both upgraded from 2.2 to 2.4)
(0004603)
_thebishop_ (reporter)
2010-07-07 14:29

It doesn't affect the hosts added after the 2.2 -> 2.4 update (I successfully re-entered my host list)
(0004604)
Mo_Hong (reporter)
2010-07-07 21:07

Ok, I re-entered or edited a host, after the error and it worked fine, it did change the value without affecting the order on the table. But I had to restart the EFW server because it did not save/reloaded with the new IP values.
(0004695)
rmuzzini (reporter)
2010-08-27 15:34
edited on: 2010-08-27 15:39

the list is messed up also by sorting it.

fast patch: you can get rid of this by editing the hosts file via ssh:

cd /var/efw/dnsmasq; nano hosts

remove the commas after last item on each line
(i.e. change "on,10.0.0.100,www,example.com," to "on,10.0.0.100,www,example.com")
save.

now you can open/sort/edit the hosts list via web browser at no risk.

(0004696)
baldy (reporter)
2010-08-27 17:16

Does not happen on a clean install of 2.4
(0004763)
peter-endian (administrator)
2010-09-20 16:19

nice catch, thank you for your help.

fixed it in repository, here's a patch for the meantime until release:

Index: hosts.cgi
===================================================================
--- hosts.cgi (revision 23602)
+++ hosts.cgi (working copy)
@@ -293,7 +293,7 @@
   my $key = 0;
   foreach my $line (@current)
   {
- $line =~ /(.*),(.*),(.*),(.*)/;
+ $line =~ /^([^,]*),([^,]*),([^,]*),([^,\n]*)/;
     @record = ('name',$key++,'IPADDR',$2,'HOSTNAME',$3,'DOMAINNAME',$4);
     $record = {}; # create a reference to empty hash
     %{$record} = @record; # populate that hash with @record

- Issue History
Date Modified Username Field Change
2010-07-06 18:54 Mo_Hong New Issue
2010-07-07 14:27 _thebishop_ Note Added: 0004602
2010-07-07 14:29 _thebishop_ Note Added: 0004603
2010-07-07 21:07 Mo_Hong Note Added: 0004604
2010-08-27 15:34 rmuzzini Note Added: 0004695
2010-08-27 15:36 rmuzzini Note Edited: 0004695
2010-08-27 15:39 rmuzzini Note Edited: 0004695
2010-08-27 17:16 baldy Note Added: 0004696
2010-09-20 16:19 peter-endian Note Added: 0004763
2010-09-20 16:19 peter-endian Status new => resolved
2010-09-20 16:19 peter-endian Resolution open => fixed
2010-09-20 16:19 peter-endian Assigned To => peter-endian
2010-09-20 16:19 peter-endian Fixed in Version => 2.4
2010-09-21 12:56 peter-endian Fixed in Version 2.4 => 2.5
2010-11-22 12:08 peter-endian Fixed in Version 2.5 => 2.4.1
2010-11-22 12:08 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker