SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0003127: Cannot access ORANGE zone from OpenVPN Roadwarrior - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003127Endian FirewallOpenVPN Client and Serverpublic2010-08-27 21:392010-11-22 12:08
Reporterdgamez 
Assigned Todgamez 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.4 
Target VersionFixed in Version2.4.1 
Summary0003127: Cannot access ORANGE zone from OpenVPN Roadwarrior
DescriptionCannot access to DMZ in ORANGE zone from OpenVPN Roadwarrior (without firewalls on the client side).

Have set all possible access rules in Port forwarding / NAT, Outgoing traffic, Inter-Zone traffic, VPN traffic, OpenVPN server configuration, OpenVPN Accounts and Advanced OpenVPN settings.

Also Firewalls on the ORANGE Servers have been disabled.
Additional InformationDocumentation says that checking the "Push route to orange zone:" on the OpenVPN Account is enough, but it isn't.
TagsNo tags attached.
Attached Filesjpg file icon openvpn.jpg [^] (119,762 bytes) 2010-08-27 21:39

- Relationships

-  Notes
(0004700)
luca-endian (developer)
2010-08-31 08:16

- check client routing table
- the only firewall which prevents traffic between vpn clients and orange is vpn firewall
(0004710)
dgamez (reporter)
2010-09-07 18:06

Thanks for reply lucagiove,

VPN firewall is desactivated. Also, I tested activating it, and creating an explicit rule to allow traffic to Orange zone.
(0004711)
luca-endian (developer)
2010-09-08 07:59

routes?
are them pushed to your roadwarrior? check it out on the command line
(0004735)
dgamez (reporter)
2010-09-18 19:06
edited on: 2010-09-18 19:10

Was not a bug, I solved it by assigning the correct Source, Destination and Gateway Networks. i.e.

LAN: 192.168.0.0/24
DMZ Network: 192.168.1.0/24

Source Network | Destination Network | Via Gateway | Remark
192.168.0.0/24 | 192.168.1.0/24 | 192.168.1.253 | GREEN to DMZ

Before, I had it in the wrong way:
Source Network | Destination Network | Via Gateway | Remark
192.168.0.0/24 | 192.168.1.0/24 | 192.168.0.253 | GREEN to DMZ

(0004736)
dgamez (reporter)
2010-09-18 19:10

Was not a bug, I solved it by assigning the correct Source, Destination and Gateway Networks. i.e.

LAN: 192.168.0.0/24
DMZ Network: 192.168.1.0/24

Source Network | Destination Network | Via Gateway | Remark
192.168.0.0/24 | 192.168.1.0/24 | 192.168.1.253 | GREEN to DMZ

Before, I had it in the wrong way:
Source Network | Destination Network | Via Gateway | Remark
192.168.0.0/24 | 192.168.1.0/24 | 192.168.0.253 | GREEN to DMZ

- Issue History
Date Modified Username Field Change
2010-08-27 21:39 dgamez New Issue
2010-08-27 21:39 dgamez File Added: openvpn.jpg
2010-08-31 08:16 luca-endian Note Added: 0004700
2010-09-07 18:06 dgamez Note Added: 0004710
2010-09-08 07:59 luca-endian Note Added: 0004711
2010-09-18 19:06 dgamez Note Added: 0004735
2010-09-18 19:09 dgamez Note Edited: 0004735
2010-09-18 19:10 dgamez Note Edited: 0004735
2010-09-18 19:10 dgamez Note Added: 0004736
2010-09-18 19:10 dgamez Status new => resolved
2010-09-18 19:10 dgamez Resolution open => fixed
2010-09-18 19:10 dgamez Assigned To => dgamez
2010-11-22 12:08 peter-endian Fixed in Version => 2.4.1
2010-11-22 12:08 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker