SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000320: mailgraph stops working - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000320Endian FirewallOther Scriptspublic2007-11-19 10:322007-12-31 19:11
Reporterpeter-endian 
Assigned Topeter-endian 
PriorityimmediateSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta1 
Target VersionFixed in Version2.2-beta2 
Summary0000320: mailgraph stops working
DescriptionMailgraph stops working because it needs to be reloaded whenever maillog files
will be rotated.

The logrotate file within postfix rpm cause the logfile to be rotated but reload only syslog-ng.
mailgraph is also reading from that file.

Maybe the tail perl module is also able to restart reading if such happens. Would be better
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000656)
peter-endian (administrator)
2007-11-22 17:38

changed File::Tail in order to not fail whenever no file exists.
Should fix this problem but needs testing

- Issue History
Date Modified Username Field Change
2007-11-19 10:32 peter-endian New Issue
2007-11-19 10:33 peter-endian Status new => assigned
2007-11-19 10:33 peter-endian Assigned To => peter-endian
2007-11-19 10:33 peter-endian Status assigned => acknowledged
2007-11-20 14:48 peter-endian Priority normal => immediate
2007-11-22 17:38 peter-endian Status acknowledged => resolved
2007-11-22 17:38 peter-endian Resolution open => fixed
2007-11-22 17:38 peter-endian Note Added: 0000656
2007-12-31 15:05 raphael-endian Fixed in Version => 2.2-beta2
2007-12-31 19:11 raphael-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker