SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000323: something eats last digit of RED_IPS of an uplink settings file - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000323Endian FirewallNetwork related (VPN, uplinks)public2007-11-20 14:532007-12-31 19:11
Reporterpeter-endian 
Assigned Topeter-endian 
PriorityimmediateSeveritycrashReproducibilityrandom
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta1 
Target VersionFixed in Version2.2-beta2 
Summary0000323: something eats last digit of RED_IPS of an uplink settings file
DescriptionA script, interface editor, network wizard, upliniks scripts, uplinksdaemon or uplinks migration script eats the last digit of RED_IPS.

It happens multiple times that for example 10.1.1.1/24 went to 10.1.1.1/2, which of course breaks things hardly.

I assume it must be the migration script, but that's not sure.

Also the CIDR variable sometimes went's empty, which is also causes the uplink not to come up anymore.

Not sure if this happens only after migration of all the time.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000687)
peter-endian (administrator)
2007-12-10 16:42

most probably this was because of chop instead of chomp within readhash() in header.pl
if it was that, this issue is fixed.

- Issue History
Date Modified Username Field Change
2007-11-20 14:53 peter-endian New Issue
2007-11-20 14:53 peter-endian Status new => assigned
2007-11-20 14:53 peter-endian Assigned To => peter-endian
2007-11-20 14:56 peter-endian Priority normal => immediate
2007-11-20 14:56 peter-endian Severity minor => crash
2007-12-10 16:42 peter-endian Note Added: 0000687
2007-12-19 18:51 peter-endian Status assigned => resolved
2007-12-19 18:51 peter-endian Fixed in Version => 2.2
2007-12-19 18:51 peter-endian Resolution open => fixed
2007-12-31 15:05 raphael-endian Fixed in Version 2.2-beta1 => 2.2-beta2
2007-12-31 19:11 raphael-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker