SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0003246: efw-upgrade fails 2.4 -> 2.4.1 - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003246Endian FirewallMigrationpublic2010-11-03 21:442010-11-05 20:10
Reportertimupci 
Assigned Tolorenzo-endian 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.4 
Target VersionFixed in Version2.4.1 
Summary0003246: efw-upgrade fails 2.4 -> 2.4.1
DescriptionWhen doing efw-upgrade on one of my EFWs I recieve the following error message.

error: file /etc/init.d conflicts between attempted installs of initscripts-2.4.1-0.endian9.i586 and chkconfig-1.3.11.2-1.i586
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0004999)
ra-endian (administrator)
2010-11-04 09:55

Sometimes smart is trying to install a old version of the same package if found in the local cache.

Can you please try to clean the cache with:
smart clean all

And with this 2 command smart is trying to check and repair the internal database:
smart check
smart fix
(0005006)
timupci (reporter)
2010-11-04 17:23

Attempted your solution twice, results were the same.


-> //xxxxx@gmail.com:*@updates.endian.org/stable/pool/util-linux-ng-2.13.1-6_WR.endian1.i586.rpm">http://xxxxx@gmail.com:*@updates.endian.org/stable/pool/util-linux-ng-2.13.1-6_WR.endian1.i586.rpm [//xxxxx@gmail.com:*@updates.endian.org/stable/pool/util-linux-ng-2.13.1-6_WR.endian1.i586.rpm" target="_blank">^]
util-linux-ng-2.13.1-6_WR.endian1.i586.rpm ################################################################ [100%]
Committing transaction...
Preparing... ################################################################ [ 0%]
error: file /etc/init.d conflicts between attempted installs of initscripts-2.4.1-0.endian9.i586 and chkconfig-1.3.11.2-1.i586
(0005009)
baldy (reporter)
2010-11-04 18:01

Encountered same issue on clean 2.4 install

error: file /etc/init.d conflicts between attempted installs of initscripts-2.4.
1-0.endian9.i586 and chkconfig-1.3.11.2-1.i586

, running efw-upgrade again downloaded 2 packages and restarted the upgrade process without problems.

-> //klaas-jan@baldy.nl:*@updates.endian.org/.../initscripts-2.4.2-0.endian">http://klaas-jan@baldy.nl:*@updates.endian.org/.../initscripts-2.4.2-0.endian [//klaas-jan@baldy.nl:*@updates.endian.org/.../initscripts-2.4.2-0.endian" target="_blank">^]
12.i586.rpm
-> //klaas-jan@baldy.nl:*@updates.endian.org/.../openswan-2.6.29-4.endian16">http://klaas-jan@baldy.nl:*@updates.endian.org/.../openswan-2.6.29-4.endian16 [//klaas-jan@baldy.nl:*@updates.endian.org/.../openswan-2.6.29-4.endian16" target="_blank">^]
_2.6.32.24_57.e38.i586.rpm
initscripts-2.4.2-0.endian12... ######################################## [ 99%]
openswan-2.6.29-4.endian16_2... ######################################## [100%]
(0005016)
lorenzo-endian (manager)
2010-11-05 12:23

Hi timupci,

the problem is related to smart which, in this case, selects initscripts-2.4.1-0.endian9.i586 instead of initscripts-2.4.1-0.endian12.i586.

As workaround, we removed the initscripts-2.4.1-0.endian9.i586 package from the repository, so that now if you do an efw-upgrade od an smart-update && smart-upgrade, the problem should be solved.

In any case, we will investigate deeply to understand why smart selects the wrong package.

Thanks for your support

Lo

- Issue History
Date Modified Username Field Change
2010-11-03 21:44 timupci New Issue
2010-11-04 09:49 ra-endian Assigned To => ra-endian
2010-11-04 09:49 ra-endian Status new => acknowledged
2010-11-04 09:55 ra-endian Note Added: 0004999
2010-11-04 10:38 ra-endian Status acknowledged => feedback
2010-11-04 17:23 timupci Note Added: 0005006
2010-11-04 17:48 ra-endian Status feedback => new
2010-11-04 17:48 ra-endian Assigned To ra-endian => lorenzo-endian
2010-11-04 18:01 baldy Note Added: 0005009
2010-11-05 12:23 lorenzo-endian Note Added: 0005016
2010-11-05 12:23 lorenzo-endian Status new => resolved
2010-11-05 12:23 lorenzo-endian Resolution open => fixed
2010-11-05 20:10 ra-endian Status resolved => closed
2010-11-05 20:10 ra-endian Fixed in Version => 2.4.1

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker