SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0003259: Kernel panic after upgrade to 2.4.1, kernel module mptsas is missing - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003259Endian FirewallHardware related (kernel, drivers, hardware)public2010-11-06 01:582010-11-15 07:24
Reportermarc 
Assigned Tolorenzo-endian 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.4 
Target VersionFixed in Version2.4.1 
Summary0003259: Kernel panic after upgrade to 2.4.1, kernel module mptsas is missing
DescriptionI did an efw-upgrade today from a running 2.3 installation. After reboot the maschine stopped with kernel panic "ERROR opening /dev/console"
I did a fresh installation of version 2.4 RESPIN on the machine, which was running fine. After efw-upgrade and reboot I ran into the same error.

I found a warning in the efw-upgrade process:
Output from kernel-3:2.6.32.24-57.e38@i586:
rootdev=/dev/root
WARNING: No module mptsas found for kernel 2.6.32.24-57.e38.i586, continuing anyway

I checked /etc/modprobe.conf which shows:
alias scsi_hostadapter ata_piix
alias eth e1000e
alias scsi_hostadapter mptsas
alias eth tg3

When I run "find / -name mpt*" on the 2.4.0 version I get:
./lib/modules/2.6.27.19-72.e25/kernel/drivers/message/fusion/mptbase.ko.gz
./lib/modules/2.6.27.19-72.e25/kernel/drivers/message/fusion/mptctl.ko.gz
./lib/modules/2.6.27.19-72.e25/kernel/drivers/message/fusion/mptfc.ko.gz
./lib/modules/2.6.27.19-72.e25/kernel/drivers/message/fusion/mptlan.ko.gz
./lib/modules/2.6.27.19-72.e25/kernel/drivers/message/fusion/mptsas.ko.gz
./lib/modules/2.6.27.19-72.e25/kernel/drivers/message/fusion/mptscsih.ko.gz
./lib/modules/2.6.27.19-72.e25/kernel/drivers/message/fusion/mptspi.ko.gz

After updating to 2.4.1 I get from "find / -name mpt*"
./lib/modules/2.6.32.24-57.e38.i586/kernel/drivers/message/fusion/mptbase.ko.gz
./lib/modules/2.6.32.24-57.e38.i586/kernel/drivers/message/fusion/mptctl.ko.gz
./lib/modules/2.6.32.24-57.e38.i586/kernel/drivers/message/fusion/mptfc.ko.gz
./lib/modules/2.6.32.24-57.e38.i586/kernel/drivers/message/fusion/mptlan.ko.gz
./lib/modules/2.6.32.24-57.e38.i586/kernel/drivers/message/fusion/mptscsih.ko.gz
./lib/modules/2.6.32.24-57.e38.i586/kernel/drivers/message/fusion/mptspi.ko.gz
./lib/modules/2.6.32.24-57.e38.i586/kernel/drivers/scsi/mpt2sas
./lib/modules/2.6.32.24-57.e38.i586/kernel/drivers/scsi/mpt2sas/mpt2sas.ko.gz

So I believe the kernel panic is a result of the missing mptsas module in the new kernel release.
Additional InformationHardware:
Dell PowerEdge 860
with Dell SAS 5 Host Bus Adapter (RAID1)
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005101)
lorenzo-endian (manager)
2010-11-12 15:56

Hello Marc,

the ISO of the version 2.4.1 has been released.

The problem which causes this problem has been fixed.

You will find it on Sourgeforce.net.

Thanks a lot
(0005112)
marc (reporter)
2010-11-15 00:33

Hi,
I've tested the 2.4.1 ISO, the controller is now detected and the mptsas module is showing up. I've also tested the update process, it installs a mptsas module now.
Thank you!
(0005113)
lorenzo-endian (manager)
2010-11-15 07:24

Hi Marc,

we are happy that now the system works as expected!

Thanks a lot for your support and tests!

Lo

- Issue History
Date Modified Username Field Change
2010-11-06 01:58 marc New Issue
2010-11-09 16:23 lorenzo-endian Assigned To => lorenzo-endian
2010-11-09 16:23 lorenzo-endian Status new => feedback
2010-11-12 15:56 lorenzo-endian Note Added: 0005101
2010-11-15 00:33 marc Note Added: 0005112
2010-11-15 07:24 lorenzo-endian Note Added: 0005113
2010-11-15 07:24 lorenzo-endian Status feedback => closed
2010-11-15 07:24 lorenzo-endian Resolution open => fixed
2010-11-15 07:24 lorenzo-endian Fixed in Version => 2.4.1
2012-05-31 08:36 marius-endian Relationship added related to 0004370

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker