SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0003307: DDNS not Working on 2.4.1 - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003307Endian FirewallOther Servicespublic2010-11-17 17:322010-12-14 10:15
Reportermschwenk 
Assigned Tomax-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version2.4 
Target VersionFixed in Version 
Summary0003307: DDNS not Working on 2.4.1
DescriptionAfter my update to 2.4.1 Dyndns is not working anymore.
I need this urgent to be able to access my Servers from everywhere since thay have a dynamic IP. Can´t use vpn as well.
I use dyndns.org/com
Additional Information/var/log/messages after force an update

sudo: nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/local/bin/setddns.pl -f 2

I didn´t change anything after update and it didn´t work. I recreated my ddns entrys on the endian but it didn´t help.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005173)
kfason (reporter)
2010-11-22 14:31

I concur this does not work in 2.4.1. I use dyndns-custom.
(0005176)
Renee (reporter)
2010-11-22 19:19

I have the same problem no update! Need fix!
(0005177)
baldy (reporter)
2010-11-22 23:11

I am using dyndns.org and configured hosts in dyndns.info and dyndns.biz. System has been upgraded from 2.3 to 2.4 and to 2.4.1 and dyndns is working properly.

Have your systems been upgraded or cleanly installed ?

regards,

Baldy
(0005178)
Renee (reporter)
2010-11-22 23:34

My system is upgraded from 2.4.0 via efw-upgrade the dyndns update does not work after reboot with the new kernel.

For me it was now finally with the Endian every time something does not function after an Upgrade and I have not the time to fix it per Remote vie Internet. So I will move the Remote system to the Astaro this works by me already since 2 months successfully. They have at least not thus a bad update politics for her Community (Home) variation!
(0005187)
mschwenk (reporter)
2010-11-23 16:46
edited on: 2010-11-23 16:49

I did an upgrade from 2.4 to 2.4.1
If needed i can grant access to my efw. Of course only limited since I´m using dsl and my IP changes every night.

(0005197)
max-endian (developer)
2010-11-24 17:35

Hi.
There is a bug in the file /usr/local/bin/setddns.pl.
line ca. 387

Please replace the following if statment:

if ($settings{'SERVICE'} = 'zoneedit')
  {$serverdir = '-s'; $serveradd = 'dynamic.zoneedit.com';}
else
  {$serverdir = ''; $serveradd = '';}

with this one:

if ($settings{'SERVICE'} eq 'zoneedit')
  {$serverdir = '-s'; $serveradd = 'dynamic.zoneedit.com';}
else
  {$serverdir = ''; $serveradd = '';}
(0005351)
anubisg1 (reporter)
2010-12-10 11:32

i wonder if an official upgrade is on the way for this bug. a feature is broken!
(0005371)
max-endian (developer)
2010-12-14 10:15

Hi
The fix will be part of the next update, but we have not decided when the next updates comes. Sorry, please use until the update bugfix.

- Issue History
Date Modified Username Field Change
2010-11-17 17:32 mschwenk New Issue
2010-11-22 14:31 kfason Note Added: 0005173
2010-11-22 19:19 Renee Note Added: 0005176
2010-11-22 23:11 baldy Note Added: 0005177
2010-11-22 23:34 Renee Note Added: 0005178
2010-11-23 13:34 ra-endian Assigned To => max-endian
2010-11-23 13:34 ra-endian Status new => assigned
2010-11-23 16:46 mschwenk Note Added: 0005187
2010-11-23 16:49 mschwenk Note Edited: 0005187
2010-11-24 17:35 max-endian Note Added: 0005197
2010-11-24 17:35 max-endian Status assigned => resolved
2010-11-24 17:35 max-endian Resolution open => fixed
2010-12-10 11:32 anubisg1 Note Added: 0005351
2010-12-10 11:32 anubisg1 Status resolved => feedback
2010-12-10 11:32 anubisg1 Resolution fixed => reopened
2010-12-14 10:15 max-endian Note Added: 0005371
2010-12-14 10:15 max-endian Status feedback => resolved
2010-12-14 10:15 max-endian Resolution reopened => fixed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker