SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0003333: Firewall diagrams don't open - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003333Endian FirewallGUIpublic2010-11-26 23:232012-01-20 08:47
Reportergmar_87 
Assigned Tomax-endian 
PrioritynormalSeveritytweakReproducibilityalways
StatusconfirmedResolutionreopened 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0003333: Firewall diagrams don't open
DescriptionAfter clicking on a firewall diagram and grey box appears with previous, next and X, but no enlarged image.
Additional InformationSee screenshot attached
Tagspurple
Attached Filesjpg file icon Firewall_diagrams_bug.jpg [^] (43,545 bytes) 2010-11-26 23:23


html file icon gallery.html [^] (1,784 bytes) 2010-12-05 22:06
? file icon gallery.mak [^] (1,589 bytes) 2010-12-05 22:07
css file icon gallery.css [^] (3,263 bytes) 2010-12-05 22:08

- Relationships

-  Notes
(0005221)
gmar_87 (reporter)
2010-11-26 23:27

/var/log/emi
************
Nov 27 10:08:38 PROXY1 emi[5123]: Could not trigger unknown action '' of class 'FirewallDiagramController'
(0005302)
max-endian (developer)
2010-12-05 22:11

Hi

Suddenly the jquery guys have removed the gallery function, so I have rewritten the code with other jquery functions.

To fix the problem please replace the the following files with the one I have uploaded:

/var/lib/python2.4/site-packages/endian/emi/templates/gallery.html
/var/lib/python2.4/site-packages/endian/emi/templates/gallery.mak
/var/lib/python2.4/site-packages/endian/emi/static/css/gallery.css

The debug message is just resolved in a other bugfix.
(0005310)
max-endian (developer)
2010-12-07 06:23

Sorry, the filepaths should be those:

/usr/lib/python2.4/site-packages/endian/emi/templates/gallery.html
/usr/lib/python2.4/site-packages/endian/emi/templates/gallery.mak
/usr/lib/python2.4/site-packages/endian/emi/static/css/gallery.css
(0005311)
gmar_87 (reporter)
2010-12-07 08:50

Thanks for the replacement files. Diagrams are now working, but i still get this in /var/log/emi

Dec 7 19:48:10 PROXY1 emi[5125]: Could not trigger unknown action '' of class 'FirewallDiagramController'
(0005315)
max-endian (developer)
2010-12-07 10:34

Hi!

Replace the following function in /var/lib/python2.4/endian/emi/controller.py or wait for the next release, because the error has no influence on the rest...:

    def processCustomAction(self,args,action):
        triggered = False
        targs = {}
        if action == "":
            return targs
        if hasattr(self, action):
            # trigger the action
            debug("Triggering action %s->%s: %s" % (self, action, args))
            targs = getattr(self, action)(**args)
            triggered = True
        if hasattr(self, "_%s" % action):
            # trigger the _action
            debug("Triggering action %s->_%s: %s" % (self, "_%s" % action, args))
            targs.update(getattr(self, '_%s'%action)(**args))
            triggered = True
        if not triggered:
            error("Could not trigger unknown action '%s' of class '%s'" % (action, self.__class__.__name__))

        return targs
(0007311)
andreluiz (reporter)
2011-08-12 14:13

hello max-endian, controllers.pyc my file is in trouble, would send the file so you can put on my firewall, the version is 2.4.1?

- Issue History
Date Modified Username Field Change
2010-11-26 23:23 gmar_87 New Issue
2010-11-26 23:23 gmar_87 File Added: Firewall_diagrams_bug.jpg
2010-11-26 23:27 gmar_87 Note Added: 0005221
2010-11-28 20:31 ra-endian Assigned To => max-endian
2010-12-05 22:06 max-endian File Added: gallery.html
2010-12-05 22:07 max-endian File Added: gallery.mak
2010-12-05 22:08 max-endian File Added: gallery.css
2010-12-05 22:11 max-endian Note Added: 0005302
2010-12-05 22:11 max-endian Status new => closed
2010-12-05 22:11 max-endian Resolution open => fixed
2010-12-07 06:23 max-endian Note Added: 0005310
2010-12-07 06:23 max-endian Status closed => resolved
2010-12-07 08:50 gmar_87 Note Added: 0005311
2010-12-07 08:50 gmar_87 Status resolved => feedback
2010-12-07 08:50 gmar_87 Resolution fixed => reopened
2010-12-07 10:34 max-endian Note Added: 0005315
2010-12-07 10:34 max-endian Status feedback => resolved
2010-12-07 10:34 max-endian Resolution reopened => fixed
2011-01-03 14:51 luca-endian Status resolved => feedback
2011-01-03 14:51 luca-endian Resolution fixed => reopened
2011-01-03 14:51 luca-endian Tag Attached: purple
2011-01-03 14:51 luca-endian Status feedback => confirmed
2011-01-20 09:23 ra-endian Customer Occurencies => 0
2011-02-18 17:43 ra-endian Severity minor => tweak
2011-08-12 14:13 andreluiz Note Added: 0007311

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker