SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0003340: Can't upgrade from 2.2 to 2.4.1 - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003340Endian FirewallInstallationpublic2010-11-30 04:592011-02-18 17:13
ReporterNarinNil 
Assigned Topeter-endian 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version2.2 
Target VersionFixed in Version 
Summary0003340: Can't upgrade from 2.2 to 2.4.1
Descriptioni fresh installed 2.2 and then upgrade to 2.4.1
but can't upgrade it's show error as below

error: file /home/httpd/html/include/servicesubscriber.js from install of efw-guilib-2.4.3-0.endian5 conflicts with file from package
efw-base-2.6.127.2-1.endian9

i try 3 times but still got error :( 2.3, 2.4, 2.4.1 can't install
on my system with raid problem

my system = hp proliant dl360 g3 (72 GB x 2 with raid 0)
TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0003407feedbackpeter-endian upgradeing using efw-upgrade 

-  Notes
(0005263)
lorenzo-endian (manager)
2010-12-02 09:22

Hi NarinNil,

we released some update, can you try it now?

Thanks in advance!

Lo
(0005273)
lorenzo-endian (manager)
2010-12-02 10:55

It seems to be a problem already reported:

http://bugs.endian.com/view.php?id=3075 [^]

could you please check it?

Thanks a lot!

Lo
(0005298)
NarinNil (reporter)
2010-12-04 02:30

Still got the problem :(
======================================================

Committing transaction...
Preparing... ####################################################################################### [ 0%]

error: file /home/httpd/html/include/servicesubscriber.js from install of efw-guilib-2.4.3-0.endian5 conflicts with file from package
efw-base-2.6.127.2-1.endian9
(0005299)
pwizard (reporter)
2010-12-04 03:36

Hi NarinNil
Try to replace file servicesubscriber.js before to upgrade.
refer to http://bugs.endian.it/view.php?id=2676 [^]
(0005300)
NarinNil (reporter)
2010-12-04 07:54

Thanks, pwizard :D
i will be feedback later
(0005318)
NarinNil (reporter)
2010-12-08 03:01

pwizard

Not work :( it's show as this link

http://upic.me/ts/i/qx/6untitled.png [^]
(0005331)
pwizard (reporter)
2010-12-09 04:50

Hi NarinNil
This issue will be same http://bugs.endian.it/view.php?id=3363. [^]
(0005333)
lorenzo-endian (manager)
2010-12-09 08:10

Hi NarinNil,

pwizard is right, at the moment we are experiencing problem with our repository (the problem will be fixed as soon as possible!).

Thanks a lot for your patient!

Lo
(0005401)
Flyrain (reporter)
2010-12-21 07:26

I have the same error. Any solution?

Loading cache...
Updating cache... ######################################## [100%]

Fetching information for 'efw-community'...
-> *@updates.endian.org/stable/.../repomd.xml">http://********************:*@updates.endian.org/stable/.../repomd.xml [*@updates.endian.org/stable/.../repomd.xml" target="_blank">^]
repomd.xml ######################################## [ 33%]

Updating cache... ######################################## [100%]

Channels have no new packages.
Loading cache...
Updating cache... ######################################## [100%]

Computing transaction...

Upgrading packages (114):
  amavisd-new libopenldap
  apache libvolume_id
  audit-libs libxml2
  basesystem libxml2-python
  conntrack-tools lm_sensors
  cyrus-sasl logrotate
  cyrus-sasl-md5 mdadm
  cyrus-sasl-plain misc-progs
  dansguardian mkinitrd
  dhclient module-init-tools
  dhcp nano
  dnsmasq net-snmp
  e2fsprogs net-snmp-libs
  e2fsprogs-libs ntop
  ebtables ntp
  efw-backup openssh
  efw-configroot openssh-clients
  efw-endian openssh-server
  efw-guilib openssl
  efw-ifup openswan
  efw-interfaceeditor openvpn
  efw-ipsec openvpn-auth
  efw-locales p3scan
  efw-mailgraph pax
  efw-netwizard perl
  efw-network perl-rrdtool
  efw-openssh postgresql-libs
  efw-syslog postgrey
  efw-upgrade ppp
  endian-artwork-community procps
  endian-core python-cheetah
  ethconfig python-iplib
  ethtool python-json
  fcron rp-pppoe
  file rrdtool
  filesystem samba
  frox samba-common
  gettext scripts
  grub sed
  gzip shadow-utils
  havp smartpm
  hwdata snort
  ifplugd speedtouch
  initscripts squid
  ipac-ng squid-radius-auth
  iptables sudo
  iputils syslog-ng
  isdn4k-utils tar
  kernel tmpwatch
  kernel-module-modem-drivers udev
  kernel-module-openswan ulogd
  krb5-libs unzip
  kudzu util-linux-ng
  libdaemon vconfig
  libnetfilter_conntrack vim
  libnetfilter_log wireless-tools
  libnfnetlink zoo

Installing packages (14):
  chkconfig mm python-htmltmpl
  device-mapper modem-drivers python-pexpect
  device-mapper-libs p7zip python-setuptools
  kernel-firmware perl-Compress-Raw-Zlib python-simplejson
  lvm2 perl-json-xs

Removing packages (1):
  net-snmp-utils

84.6MB of package files are needed. 67.0MB will be used.

Committing transaction...
Preparing... ######################################## [ 0%]
error: file /home/httpd/html/include/servicesubscriber.js from install of efw-guilib-2.4.3-0.endian5 conflicts with file from package efw-base-2.6.127.2-1.endian9
(0005428)
sifi986 (reporter)
2010-12-31 04:15

I have attempted to upgrade two Endian 2.2 firewalls to 2.4.1 using efw-upgrade and this problem seems to have returned with package conflicts.

 efw-upgrade
Loading cache...
Updating cache... #################################################### [100%]

Fetching information for 'efw-community'...
-> //endian@sitek.co.nz:*@updates.endian.org/stable/repodata/repomd.xml">http://endian@sitek.co.nz:*@updates.endian.org/stable/repodata/repomd.xml [//endian@sitek.co.nz:*@updates.endian.org/stable/repodata/repomd.xml" target="_blank">^]
repomd.xml #################################################### [ 33%]

Updating cache... #################################################### [100%]

Channels have no new packages.
Loading cache...
Updating cache... #################################################### [100%]

Computing transaction...

Upgrading packages (111):
Installing packages (17):

84.2MB of package files are needed. 74.6MB will be used.

Committing transaction...
Preparing... #################################################### [ 0%]
error: file /home/httpd/html/include/servicesubscriber.js from install of efw-guilib-2.4.3-0.endian5 conflicts with file from package efw-base-2.6.127.2-1.endian9

I have attempted to upgrade many times over last 12 months and each time this fails.
(0005445)
lorenzo-endian (manager)
2011-01-05 15:41

Hi everybody,

we have released a new package on the community channel which solves the problem on my testing machine.

Could you try to upgrade now?

Let me know if the problem is solved :-)

Have a nice day

Lo
(0005455)
sifi986 (reporter)
2011-01-05 21:07

Hello,

After running efw-upgrade it does not appear to download any new or an updated package that you mention. I am still getting this after running efw-upgrade

Loading cache...
Updating cache...
Fetching information for 'efw-community'...
-> //endian@sitek.co.nz:*@updates.endian.org/stable/repodata/repomd.xml">http://endian@sitek.co.nz:*@updates.endian.org/stable/repodata/repomd.xml [//endian@sitek.co.nz:*@updates.endian.org/stable/repodata/repomd.xml" target="_blank">^]
repomd.xml
Updating cache...
Channels have no new packages.
Loading cache...
Updating cache...
Computing transaction...
Upgrading packages (111):
Installing packages (17):
84.2MB of package files are needed. 74.6MB will be used.
Committing transaction...
Preparing...
error: file /home/httpd/html/include/servicesubscriber.js from install of efw-guilib-2.4.3-0.endian5 conflicts with file from package efw-base-2.6.127.2-1.endian9




I have tried,

smart update Channels have no new packages.
smart check Loading cache... Updating cache...
smart fix No problems to resolve!


smart upgrade --> final result is
servicesubscriber.js from install of efw-guilib-2.4.3-0.endian5 conflicts

smart install efw-base --> final result is
error: Can't install python-2.4.6-18.endian7@i586: no package provides libbz2.so.1

smart clean all --> all packages were re-downloaded and then the same error servicesubscriber.js from install of efw-guilib-2.4.3-0.endian5 conflicts


Thanks
Simon M Knight
SiTek NZ Ltd

- Issue History
Date Modified Username Field Change
2010-11-30 04:59 NarinNil New Issue
2010-12-02 09:22 lorenzo-endian Note Added: 0005263
2010-12-02 09:22 lorenzo-endian Assigned To => lorenzo-endian
2010-12-02 09:22 lorenzo-endian Status new => feedback
2010-12-02 10:55 lorenzo-endian Note Added: 0005273
2010-12-04 02:30 NarinNil Note Added: 0005298
2010-12-04 03:36 pwizard Note Added: 0005299
2010-12-04 07:54 NarinNil Note Added: 0005300
2010-12-08 03:01 NarinNil Note Added: 0005318
2010-12-09 04:50 pwizard Note Added: 0005331
2010-12-09 08:10 lorenzo-endian Note Added: 0005333
2010-12-21 07:26 Flyrain Note Added: 0005401
2010-12-31 04:15 sifi986 Note Added: 0005428
2011-01-03 11:11 lorenzo-endian Relationship added has duplicate 0003407
2011-01-05 15:41 lorenzo-endian Note Added: 0005445
2011-01-05 21:07 sifi986 Note Added: 0005455
2011-01-07 15:41 lorenzo-endian Status feedback => confirmed
2011-02-02 13:48 lorenzo-endian Customer Occurencies => 0
2011-02-02 13:48 lorenzo-endian Assigned To lorenzo-endian => peter-endian
2011-02-17 09:16 lorenzo-endian Severity major => block
2011-02-18 17:13 ra-endian Status confirmed => closed
2011-02-18 17:13 ra-endian Resolution open => duplicate

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker