SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0003349: static ethernet uplink comes up with wrong configuration or not at all due to missing cidrinfo - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003349Endian FirewallNetwork related (VPN, uplinks)public2010-12-02 15:182011-07-05 10:13
Reporterpeter-endian 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityrandom
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.4 
Target Version2.4Fixed in Version2.5 
Summary0003349: static ethernet uplink comes up with wrong configuration or not at all due to missing cidrinfo
Descriptionpython-iplib changed /usr/bin/cidrinfo to /usr/bin/cidrinfo.py
uplink scripts (generic/route.sh, generic/data.sh) still call cidrinfo, which return '', which will be interpreted as 0.0.0.0

upkink configuration then ends up in wrong routing configuration installing a route of 0.0.0.0/24 for the uplink device.

sometimes the uplink is then not working at all.
it's unsure when exactly, with which configuration, but if definitively happens
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2010-12-02 15:18 peter-endian New Issue
2010-12-02 15:18 peter-endian Status new => confirmed
2010-12-02 15:19 peter-endian Status confirmed => resolved
2010-12-02 15:19 peter-endian Fixed in Version => 2.5
2010-12-02 15:19 peter-endian Resolution open => fixed
2010-12-02 15:19 peter-endian Assigned To => peter-endian
2011-07-05 10:13 lorenzo-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker