SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0003355: Reboot Required - Always on the dashboard - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003355Endian FirewallGUIpublic2010-12-03 16:492012-09-11 14:17
Reporterardit-endian 
Assigned Tolorenzo-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version2.4 
Target VersionFixed in Version 
Summary0003355: Reboot Required - Always on the dashboard
DescriptionOn one system after a major upgrade (Software appliance) on the dashboard was the message "Reboot required" and this is normal, after different reboots the message still show himself on the dashboard.

I removed the file /tmp/oldkernel instantly the "reboot required" disappeared and to be sure I rebooted the firewall and I didn't see anymore the reboot required (fine).

But after some time the the message is still there and I after any try (rebuild db, syncronise with endian network, run endian-update upgrade, smart checks etc, reinstalled efw-guilib) but the message is still there.

Regards.
Tagspurple
Attached Files

- Relationships
related to 0002550closedsimon-endian Message on the gui for a new kernel installed 

-  Notes
(0005305)
ra-endian (administrator)
2010-12-06 14:52

And after 1 hour the problem still exists?

The checkkernel script is running by cron every hour (/etc/cron.hourly/checkkernel)
(0005307)
ardit-endian (developer)
2010-12-06 15:51

Yes, even after 2 days or different reboots.
(0005357)
lorenzo-endian (manager)
2010-12-10 16:58

hey Ardit,

how did you do the upgrade?

Thanks in advance!

Lo
(0005382)
thomas-endian (developer)
2010-12-15 16:40

The same problem after the last 25 updates.
kernel-2.6.32.26-57.e40.i586.rpm
kernel-firmware-2.6.32.26-57.e40.i586.rpm
kernel-module-e1000e-1.2.20-2.endian1_2.6.32.26_57.e40.i586.rpm
kernel-module-igb-2.4.8-2.endian1_2.6.32.26_57.e40.i586.rpm
kernel-module-ixgbe-2.0.44.14-2.endian1_2.6.32.26_57.e40.i586.rpm
kernel-module-modem-drivers-2.4-17_2.6.32.26_57.e40.i586.rpm
kernel-module-openswan-2.6.29-4.endian17_2.6.32.26_57.e40.i586.rpm
modem-drivers-2.4-17_2.6.32.26_57.e40.i586.rpm
and so on...

We install a 2.4.0 on VMware (a complete new install), no major upgrade.

Plaese check the check-kernel.sh script, thanks
(0005385)
ardit-endian (developer)
2010-12-16 15:02

root@efw:/lib/modules # ls
2.6.32.25-57.e40.i586 2.6.32.26-57.e40.i586

This was on a 2.4 system where I just installed the new kernel + modules that were available on the updates.
BTW the folder of the .25 kernel is empty but is not deleted automatically.

On the messages log I saw this message repeating quite often:
warning: process `kudzu' used the deprecated sysctl system call with 1.23.
(0005411)
luca-endian (developer)
2010-12-22 17:09

seems that the problem is due to more than one kernel installed:

root@gi-joe:/lib/modules # rpm -q kernel
kernel-2.6.32.25-57.e40
kernel-2.6.32.26-57.e40
(0005412)
ben-endian (reporter)
2010-12-22 17:17

Had the same problem on a fresh 2.4 SW Enterprise installation. Removed the old kernel (rpm -ev kernel-2.6.32.25-57.e40) and the check-kernel script runs fine with no more dashboard errors about reboots. Not sure why this problem would exist on a fresh ISO install of the new 2.4 release?

Thanks to Luca for his help on this issue :)!
(0005413)
luca-endian (developer)
2010-12-22 17:21

rpm -ev kernel-2.6.32.25-57.e40 solved the problem
(0005722)
lorenzo-endian (manager)
2011-02-17 09:06

Hello everybody,

during all the upgrade I have done this problem is never appeared.

Could you please advise me when the problem arises on the next machine so I can connect to it and try to troubleshoot the problem?

Thanks in advance

Lo
(0005900)
lorenzo-endian (manager)
2011-03-09 10:57

Hello everybody,

during the last month (and the last 50-70 upgrades), this problem never arises, so I am going to close this ticket.

Please feel free to reopen it if the problem arises again.

Thanks in advance!

Lo
(0008131)
ardit-endian (developer)
2012-09-11 14:16

Hi Lo,

it happened again, but I can say for sure that this problem is related to smart crashing sometimes during package installation, on many 2.4 firewalls I remember finding efw-firewall installed 2 times, or other packages. It's the same with the kernel.

The script check for the kernel version, finds an old one installed why the new one is also in the db and "thinks" that a reboot is required.

Just to update the bug, you can close it again.

- Issue History
Date Modified Username Field Change
2010-12-03 16:49 ardit-endian New Issue
2010-12-06 08:32 luca-endian Relationship added related to 0002550
2010-12-06 14:52 ra-endian Note Added: 0005305
2010-12-06 15:34 luca-endian Tag Attached: purple
2010-12-06 15:51 ardit-endian Note Added: 0005307
2010-12-10 14:21 ra-endian Assigned To => lorenzo-endian
2010-12-10 16:58 lorenzo-endian Note Added: 0005357
2010-12-15 16:40 thomas-endian Note Added: 0005382
2010-12-16 15:02 ardit-endian Note Added: 0005385
2010-12-22 17:09 luca-endian Note Added: 0005411
2010-12-22 17:17 ben-endian Note Added: 0005412
2010-12-22 17:21 luca-endian Note Added: 0005413
2011-02-17 09:06 lorenzo-endian Note Added: 0005722
2011-02-17 09:06 lorenzo-endian Status new => feedback
2011-03-09 10:57 lorenzo-endian Note Added: 0005900
2011-03-09 10:57 lorenzo-endian Status feedback => closed
2011-03-09 10:57 lorenzo-endian Resolution open => fixed
2012-09-11 14:16 ardit-endian Note Added: 0008131
2012-09-11 14:16 ardit-endian Status closed => feedback
2012-09-11 14:16 ardit-endian Resolution fixed => reopened
2012-09-11 14:17 ardit-endian Status feedback => closed
2012-09-11 14:17 ardit-endian Resolution reopened => no change required

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker