SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000344: Feature Request: Incorporate new OpenVPN build - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000344Endian FirewallNetwork related (VPN, uplinks)public2007-11-26 13:042008-04-23 17:42
Reporternicoprenzel 
Assigned Topeter-endian 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta1 
Target VersionFixed in Version2.2-beta4 
Summary0000344: Feature Request: Incorporate new OpenVPN build
DescriptionHi Endian supporters,

I would highly encourage to upgrade OpenVPN to the latest version available.
I'll explain you the reasons why I am nagging on this.

Since release 2.0.1-rc7 OpenVPN supports the newer compression library LZO2 (http://www.oberhumer.com/opensource/lzo/lzonews.php [^])
This release incorporates some small performance improvements if OpenVPN is beeing build with an LZO2 library linked.
OpenVPN-Changelog:
2005.07.21 -- Version 2.0.1-rc7
* Support LZO 2.01 which renamed its library to lzo2.

So, i would encourage you to upgrade to the latest lzo2 release 2.02 and build OpenVPN with it linked.

As from OpenVPN release 2.1-beta1, openvpn-server is able to push the preferred compression setting (on/off/adaptive) to the clients (if they support it)
OpenVPN-Changelog:
2005.10.01 -- Version 2.1-beta1
* Made LZO setting pushable.

Since OpenVPN 2006.02.16 -- Version 2.1-beta9, there is also a real nice feature.
--port-share host port
When run in TCP server mode, share the OpenVPN port with another application, such as an HTTPS server. If OpenVPN senses a connection to its port which is using a non-OpenVPN protocol, it will proxy the connection to the server at host:port. Currently only designed to work with HTTP/HTTPS, though it would be theoretically possible to extend to other protocols such as ssh.

All these and a lot more features has been rock solid for about one year. I do use all these features since they were introduced.
So, please consider to move to an rock solid Version 2.1_rc4. As you could easily see, is there no real movement on the OpenVPN developer list. The last OpenVPN release RC4 is from 2007.04.25 and on the developer list there are a lot of questions on a final release since there are no real known problems.
(see here http://article.gmane.org/gmane.network.openvpn.devel/2036 [^])

Greetings.

NicoP.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000889)
peter-endian (administrator)
2008-02-04 15:14

upgraded to 2.1_rc7

- Issue History
Date Modified Username Field Change
2007-11-26 13:04 nicoprenzel New Issue
2007-11-26 13:04 nicoprenzel Status new => assigned
2007-11-26 13:04 nicoprenzel Assigned To => peter-endian
2008-02-04 15:14 peter-endian Status assigned => resolved
2008-02-04 15:14 peter-endian Fixed in Version => 2.2-rc1
2008-02-04 15:14 peter-endian Resolution open => fixed
2008-02-04 15:14 peter-endian Note Added: 0000889
2008-03-04 14:43 ra-endian Fixed in Version 2.2-rc1 => 2.2-beta4
2008-04-23 17:42 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker