SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000036: Change NTP from NTPDate to NTPD - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000036Endian FirewallGUIpublic2006-10-02 13:542007-01-02 07:55
Reporterkfason 
Assigned Topeter-endian 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2 
Target VersionFixed in Version2.1 
Summary0000036: Change NTP from NTPDate to NTPD
DescriptionI am requesting that the NTP mechanism be changed from NTPDate to NTPd. Seems kinda harsh for NTPDate to force the time every hour instead of letting NTPd adjust it as needed.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000055)
peter-endian (administrator)
2006-10-05 23:02

well, this is because the ntp restart script is not yet a python script which easily produces the ntp configuration file using cheetah.
in this manner it simply was easier for us to implement the give functionality of a ntp server, which publishes the *local* time and don't update if the user would like to keep it's own time for what reason ever.
as soon as we have cheetah templates the cron-ntpdate script will disappear, since the checkbox "dont automatically synchronize" may control the sync behaviour of ntpd.
i also planned to give the possibility to change the timezone within this cgi...
(0000059)
peter-endian (administrator)
2006-10-25 20:43

is implemented now. will be shipped with the next release

- Issue History
Date Modified Username Field Change
2006-10-02 13:54 kfason New Issue
2006-10-05 23:02 peter-endian Note Added: 0000055
2006-10-05 23:02 peter-endian Assigned To => peter-endian
2006-10-05 23:02 peter-endian Status new => acknowledged
2006-10-25 20:43 peter-endian Status acknowledged => resolved
2006-10-25 20:43 peter-endian Resolution open => fixed
2006-10-25 20:43 peter-endian Note Added: 0000059
2007-01-02 07:55 ra-endian Status resolved => closed
2007-01-02 07:55 ra-endian Fixed in Version => 2.1

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker