SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000360: proxy.pac not working - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000360Endian FirewallNetwork related (VPN, uplinks)public2007-11-30 16:052007-12-31 19:15
Reporterm4him 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version2.2-beta2 
Summary0000360: proxy.pac not working
Descriptionusing version 2.2b1

I am trying to automate the proxy scripts but the proxy.pac is not working

It works just fine on another system with an Apace server.
I am testing it with just the basic

function FindProxyForURL(url, host)
{

return "PROXY 192.168.3.1:8080";

}
I have the automatic scripts set in firefox (and explorer 7) set to:
http://192.168.3.1/wpad.dat [^] (also tried http://192.168.3.1/proxy.pac [^])
works fine with the same script but having firefox/IE set to
http://192.168.3.3/wpad.dat [^]

I also added to the httpd.conf file
AddType application/x-ns-proxy-autoconfig .pac
and tried
AddType application/x-ns-proxy-autoconfig .dat

It still does not work from the Endian firewall but works fine from another apache server.

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000676)
m4him (reporter)
2007-11-30 20:11

I just noticed there are error in the endian proxy.pac script.

my $proxydir = $swroot."proxy/advanced/";
my $PROXY_ENABLED = $swroot."proxy/enable_";
my $PROXY_SETTINGS = $swroot."proxy/advanced/settings";
my $ETHER_SETTINGS = $swroot."ethernet/settings";
my %net_conf;
my $routingfile = $swroot."routing/config";

There is no advanced nor routing directory
I was able to edit the proxy settings directory but I do not know what the 2.2b1 equivalent of the routing config file is.

Even with the edit the script does not work.
(0000678)
peter-endian (administrator)
2007-12-01 21:42

wrong directory for proxy settings file has been fixed, thank you!

the routing directory is for the routing editor, which is available only within enterprise version, but should not make any difference.

which error do you get exactly after the edit?
(0000679)
peter-endian (administrator)
2007-12-01 21:44

btw: don't add AddType application/x-ns-proxy-autoconfig for .pac and .dat

Both are handled as cgi, since our proxy.pac/wpad.dat in fact is a cgi and generates the real proxy.pac code on the fly.
The mime-type will be printed out then by the cgi.
(0000690)
peter-endian (administrator)
2007-12-10 16:58

fixed.. isn't it?

- Issue History
Date Modified Username Field Change
2007-11-30 16:05 m4him New Issue
2007-11-30 16:05 m4him Status new => assigned
2007-11-30 16:05 m4him Assigned To => peter-endian
2007-11-30 20:11 m4him Note Added: 0000676
2007-12-01 21:42 peter-endian Note Added: 0000678
2007-12-01 21:42 peter-endian Status assigned => feedback
2007-12-01 21:44 peter-endian Note Added: 0000679
2007-12-10 16:58 peter-endian Status feedback => resolved
2007-12-10 16:58 peter-endian Fixed in Version => 2.2
2007-12-10 16:58 peter-endian Resolution open => fixed
2007-12-10 16:58 peter-endian Note Added: 0000690
2007-12-31 19:15 raphael-endian Fixed in Version 2.2-beta1 => 2.2-beta2
2007-12-31 19:15 raphael-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker