SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000362: DHCP failure - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000362Endian FirewallOther Servicespublic2007-12-05 14:432008-02-02 07:28
ReporterCIURI 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta1 
Target VersionFixed in Version 
Summary0000362: DHCP failure
DescriptionDhcp server doesn't work in 2.2beta1 because the scrips have some config errors.
I fixed half of the problem but I don't know python programming so I cannot make the restartdhcp.py script to transform the binary netmask YY to the extended netmask 255.255.255.0 for example needed for the dhcpd.conf to work.

The second problem was with the range of the dhcp leases that I fixed.

I will need a bit help to fix the netmask problem.
TagsNo tags attached.
Attached Files? file icon restartdhcp.py [^] (12,540 bytes) 2007-12-05 14:43
? file icon dhcpd.conf.tmpl [^] (1,339 bytes) 2007-12-05 14:43

- Relationships
duplicate of 0000293closedpeter-endian Netwizard writes down NETMASK in CIDR notation 

-  Notes
(0000689)
peter-endian (administrator)
2007-12-10 16:54

This issue was created by the netwizard which writes it's configuration file wrongly. See the related bug.

If you fix it like described within bug 0000293, it should work also with the original restartscript file.
(0000746)
peter-endian (administrator)
2008-01-08 15:56

think this one should work now
please reopen if it does'nt

- Issue History
Date Modified Username Field Change
2007-12-05 14:43 CIURI New Issue
2007-12-05 14:43 CIURI File Added: restartdhcp.py
2007-12-05 14:43 CIURI File Added: dhcpd.conf.tmpl
2007-12-10 16:52 peter-endian Relationship added duplicate of 0000293
2007-12-10 16:54 peter-endian Note Added: 0000689
2007-12-10 16:54 peter-endian Status new => feedback
2008-01-08 15:56 peter-endian Status feedback => resolved
2008-01-08 15:56 peter-endian Resolution open => fixed
2008-01-08 15:56 peter-endian Assigned To => peter-endian
2008-01-08 15:56 peter-endian Note Added: 0000746
2008-02-02 07:28 raphael-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker