SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000370: [HTTP Proxy] When using LDAP auth and save configuration, file squid.conf is zero size. - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000370Endian FirewallOther Servicespublic2007-12-12 17:112008-02-02 07:28
Reporterrick67 
Assigned Tosimon-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.1.2 
Target Version2.2-beta3Fixed in Version2.2-beta3 
Summary0000370: [HTTP Proxy] When using LDAP auth and save configuration, file squid.conf is zero size.
DescriptionHi,

Windows authentication is working well, but when i try to enable LDAP auth against an Active Directory domain, i noticed that the squid daemon doesn't start with error: "acl name 'all' not defined!".

Looking to configuration files, i noticed that the file /var/efw/proxy/squid.conf is zero byte lenght.

So i copy /var/efw/proxy/squid.conf.tpl over /var/efw/proxy/squid.conf, and the the squid restarted correctly.

Going to efw web UI and selecting "proxy/save and restart" is revert /var/efw/proxy/squid.conf to zero bytes.

Riccardo.
TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0000445closedsimon-endian Active Directory Authentication Crash 

-  Notes
(0000695)
peter-endian (administrator)
2007-12-12 17:46

On which version does this happen?
(0000699)
rick67 (reporter)
2007-12-15 10:59

Version is 2.1.2 Community edition.
I just get the last iso and installed from it.

Riccardo.
(0000791)
simon-endian (developer)
2008-01-11 16:13

when choosen ldap as auth type empty squid conf is produced
(0000793)
simon-endian (developer)
2008-01-11 16:57

filecheck for ldapuser file failed in restartscript because it does not exist when ladp auth ist activated the first time

- Issue History
Date Modified Username Field Change
2007-12-12 17:11 rick67 New Issue
2007-12-12 17:46 peter-endian Note Added: 0000695
2007-12-12 17:46 peter-endian Status new => feedback
2007-12-12 23:10 rick67 Note Added: 0000696
2007-12-12 23:11 rick67 Note Edited: 0000696
2007-12-12 23:12 rick67 Note Edited: 0000696
2007-12-15 10:58 rick67 Note Deleted: 0000696
2007-12-15 10:59 rick67 Note Added: 0000699
2007-12-15 10:59 rick67 Status feedback => acknowledged
2008-01-11 15:10 ra-endian Assigned To => simon-endian
2008-01-11 16:13 simon-endian Note Added: 0000791
2008-01-11 16:13 simon-endian Status acknowledged => confirmed
2008-01-11 16:16 simon-endian Relationship added related to 0000445
2008-01-11 16:56 simon-endian Relationship deleted related to 0000445
2008-01-11 16:56 simon-endian Relationship added has duplicate 0000445
2008-01-11 16:57 simon-endian Status confirmed => resolved
2008-01-11 16:57 simon-endian Fixed in Version => 2.2-beta3
2008-01-11 16:57 simon-endian Resolution open => fixed
2008-01-11 16:57 simon-endian Note Added: 0000793
2008-01-11 17:04 ra-endian Target Version => 2.2-beta3
2008-01-14 16:58 ra-endian Summary When using LDAP auth and save configuration, file squid.conf is zero size. => [HTTP Proxy] When using LDAP auth and save configuration, file squid.conf is zero size.
2008-02-02 07:28 raphael-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker