SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0004009: EFW 2.4.0 CE - crash of the web admin interface and of the SSH access - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004009Endian FirewallGUIpublic2011-07-19 19:512011-09-14 15:39
Reporterlogicasrl 
Assigned Tolorenzo-endian 
PrioritynormalSeveritycrashReproducibilitysometimes
StatusfeedbackResolutionopen 
PlatformOSOS Version
Product Version2.4 
Target VersionFixed in Version 
Summary0004009: EFW 2.4.0 CE - crash of the web admin interface and of the SSH access
DescriptionHi all,

I've got an EFW 2.4.0 Community Edition installed on a physical machine and I'm experiencing several "crash" of the web interface (https://<ip>:10443, [^] where the ip is the "green" interface).

Sometimes it does not respond at all (but if I do a "telnet <ip> 80" or "telnet <ip> 10443" I am able to connect to the web server...), in other cases I manage to authenticate and navigate, but at some point it stops responding and shows me a blanck page...

All the rest goes on working normally: firewall, OpenVPN, NAT, everything works, with the exception of the web interface...

In several cases the SSH access too is blocked: it prompt me with the username and password requests, but when I insert them, it refuses to authenticate (even if I am absolutely sure to input the username and password correctly).

The frequency of the problem is more or less once a week... and every time it happens I must "hard shutdown" the firewall and start it again.

Thank you very much for your help,

Luca
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0007288)
lorenzo-endian (manager)
2011-08-10 14:39

Hi Logicasrl,

does the "hard shutdown" solve the problem?

Moreover, I would ask to you, if it is possible, to try the version 2.4.1 .. I am using it and I never get these problems.

When this problem happens, do you have the possibility to connect to the serial console and check the system load, what the system is doing (with "pstree -au" and "top") and if in the logs there is any error? Otherwise you can check the log after the "hard shutdown" to see if some info are there.

Thanks in advance!

Lo
(0007408)
logicasrl (reporter)
2011-09-14 15:39
edited on: 2011-09-14 15:40

Sorry for my late answer, I was extremely busy lately.

Yes, the "hard shutdown" solve the problem, but then (sometimes after few hours, sometimes after some days) the problem comes back again.
Generally when the problem occurs even the "serial console" (SSH) is blocked: it shows me the prompt, but it does not accept my attempt to connect with "root" user.

Could you please give me detailed instructions to do the upgrade to the 2.4.1 version?

Thank you very much
L


- Issue History
Date Modified Username Field Change
2011-07-19 19:51 logicasrl New Issue
2011-08-10 14:39 lorenzo-endian Note Added: 0007288
2011-08-10 14:39 lorenzo-endian Assigned To => lorenzo-endian
2011-08-10 14:39 lorenzo-endian Status new => feedback
2011-09-14 15:39 logicasrl Note Added: 0007408
2011-09-14 15:40 logicasrl Note Edited: 0007408

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker