SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000408: Can't forwarding same port on two uplink ! - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000408Endian FirewallFirewall (iptables)public2008-01-03 13:312008-02-02 07:28
Reportertethien 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta2 
Target VersionFixed in Version2.2-beta3 
Summary0000408: Can't forwarding same port on two uplink !
DescriptionIf you created a Port forwarding rule forward port 80 on main uplink to ip address x.x.x.a then you can'n create other rule forwarding port 80 on secont uplink to ip x.x.x.b.
It display error "Source port 80 in use".
But if I modify config file by manual. forwarding is working well.

Sorry fo my english.
TagsNo tags attached.
Attached Filesjpg file icon Port_forward_1.JPG [^] (14,097 bytes) 2008-01-09 12:44


jpg file icon Port_ forward_2.JPG [^] (42,889 bytes) 2008-01-09 12:45


jpg file icon Port_ forward_3.JPG [^] (51,749 bytes) 2008-01-09 12:45


patch file icon fix.patch [^] (1,449 bytes) 2008-01-09 19:51 [Show Content]

- Relationships

-  Notes
(0000734)
peter-endian (administrator)
2008-01-08 11:57

Are you sure you did not used the same uplink with the same alias ip?
Can you please retry?

I could not reproduce this.
I successfully created the following port forwardings from port 80 to port 80:
- uplink main x.x.x.a to y.y.y.a
- uplink main x.x.x.b to y.y.y.b
- uplink test x.x.x.c to y.y.y.a
- uplink test x.x.x.d to y.y.y.b
(0000749)
tethien (reporter)
2008-01-09 12:44

I am using two PPPoE uplink.
Like picture Port_forward_1.JPG attached (i edited config file by hand).
I click edit . ( picture Port_forward_2.JPG )
I changed nothing and press "Update" button.
The Endian system report error "Source port 80 in use" ( picture Port_forward_3.JPG )
(0000755)
peter-endian (administrator)
2008-01-09 19:38

now i was able to reproduce it.
thank you for your explainations, i will fix it.
(0000756)
peter-endian (administrator)
2008-01-09 19:51

fixed it
if you like you can apply the attached patch on your system, that should do the job

- Issue History
Date Modified Username Field Change
2008-01-03 13:31 tethien New Issue
2008-01-03 13:31 tethien Status new => assigned
2008-01-03 13:31 tethien Assigned To => peter-endian
2008-01-08 11:57 peter-endian Note Added: 0000734
2008-01-08 11:57 peter-endian Status assigned => feedback
2008-01-09 12:44 tethien Note Added: 0000749
2008-01-09 12:44 tethien File Added: Port_forward_1.JPG
2008-01-09 12:45 tethien File Added: Port_ forward_2.JPG
2008-01-09 12:45 tethien File Added: Port_ forward_3.JPG
2008-01-09 19:38 peter-endian Note Added: 0000755
2008-01-09 19:38 peter-endian Status feedback => confirmed
2008-01-09 19:51 peter-endian File Added: fix.patch
2008-01-09 19:51 peter-endian Status confirmed => resolved
2008-01-09 19:51 peter-endian Fixed in Version => 2.2-beta3
2008-01-09 19:51 peter-endian Resolution open => fixed
2008-01-09 19:51 peter-endian Note Added: 0000756
2008-02-02 07:28 raphael-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker