SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0004241: Endian does not resolve DNS names - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004241Endian FirewallNetwork related (VPN, uplinks)public2012-01-12 22:352012-11-11 00:09
Reportergennarom 
Assigned ToAnonymous 
PrioritynormalSeverityblockReproducibilityalways
StatusresolvedResolutionreopened 
PlatformOSOS Version
Product Version2.5 
Target VersionFixed in Version 
Summary0004241: Endian does not resolve DNS names
DescriptionEndian does not resolve domain names and this causes internet services don't work.
Simple IP connectivity, instead, works fine.

I installed a fresh 2.5 release on a VMWare virtual machine.
Also, i installed a 2.3 release on the same VM and all works fine!...so the problem is in the newer one.
TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0004283closed Proxy HTTP DNS failure 

-  Notes
(0007627)
christian-endian (administrator)
2012-01-12 22:40

What kind of uplink did you use?
(0007628)
gennarom (reporter)
2012-01-12 22:54

Gateway, in both releases
(0007663)
christian-endian (administrator)
2012-01-30 09:32

We cannot reproduce this here...
Can you post your configuration?
(0007669)
gennarom (reporter)
2012-01-30 21:50
edited on: 2012-01-30 22:15

Breaking news...same issues with 2.5.1

In network configuration, using DNS servers located inside the green zone, same network of green interface (AD controllers), nothing works...but...using public ip for dns servers, it works fine again!!!
In this way, proxy service does not resolve host names on internal lan!


Initial network config:
Green: 192.168.2.13/16
DNS1: 192.168.1.21 (after: 212.216.112.112)
DNS2: 192.168.1.22 (after: 212.216.172.62)
GW: 192.168.0.5

Maybe issue located on accessing DNS service on hosts in LAN?

This issue is NOT present on 2.3 release that works well with LAN ip for DNS servers. (on same virtual machine for both 2.3 and 2.5.*)

(0007684)
christian-endian (administrator)
2012-02-01 10:53

In this case use the external nameservers when configuring the uplink.
To configure domains that are to be resolved internally use `Proxy->DNS->DNS Routing`.
(0007686)
gennarom (reporter)
2012-02-01 18:46

Sorry but this doesn't work....also dns routing doesn't work using internal lan servers...the issue is the same...firewall forbids access on dns service in inside lan!
(0007882)
deugenin (reporter)
2012-05-31 15:51

This can be solved temporarily executing:

ip rule del from all fwmark 0x8/0x7f8 lookup uplink-main

- Issue History
Date Modified Username Field Change
2012-01-12 22:35 gennarom New Issue
2012-01-12 22:40 christian-endian Note Added: 0007627
2012-01-12 22:40 christian-endian Status new => feedback
2012-01-12 22:54 gennarom Note Added: 0007628
2012-01-30 09:32 christian-endian Note Added: 0007663
2012-01-30 21:50 gennarom Note Added: 0007669
2012-01-30 22:15 gennarom Note Edited: 0007669
2012-02-01 10:53 christian-endian Note Added: 0007684
2012-02-01 11:59 christian-endian Status feedback => closed
2012-02-01 11:59 christian-endian Resolution open => no change required
2012-02-01 18:46 gennarom Note Added: 0007686
2012-02-01 18:46 gennarom Status closed => feedback
2012-02-01 18:46 gennarom Resolution no change required => reopened
2012-04-03 12:27 christian-endian Relationship added has duplicate 0004283
2012-05-31 15:51 deugenin Note Added: 0007882
2012-07-22 10:11 Anonymous Status feedback => resolved
2012-07-22 10:11 Anonymous Assigned To => Anonymous

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker