SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0004299: No Browsing when enebling proxy - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004299Endian FirewallProxy HTTPpublic2012-03-13 05:162012-04-04 16:33
Reporteramitk 
Assigned Todavide-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusfeedbackResolutionopen 
PlatformOSOS Version
Product Version2.5 
Target VersionFixed in Version 
Summary0004299: No Browsing when enebling proxy
DescriptionI have installed endian 2.5.1 and also tried endian 2.4.1 version at one of my site (fresh installation). But the strange problem I am facing is whenever I enable my proxy in whatever mode (Transparent or non transparent) browsing gets stopped.
In the squid proxy logs it is showing TCP_MISS/503 error.
Followings are the proxy access logs:

Mar 12 23:54:32 efw-1331566574 squid[15911]: 1331576672.194 50 192.168.0.253 TCP_MISS/000 1762 CONNECT 192.168.0.1:10443 - FIRST_UP_PARENT/havp -
Mar 12 23:54:32 efw-1331566574 squid[15911]: 1331576672.599 49 127.0.0.1 TCP_MISS/200 1418 CONNECT 192.168.0.1:10443 - DIRECT/192.168.0.1 -
Mar 12 23:54:32 efw-1331566574 squid[15911]: 1331576672.600 50 192.168.0.253 TCP_MISS/000 1762 CONNECT 192.168.0.1:10443 - FIRST_UP_PARENT/havp -
Mar 12 23:55:56 efw-1331566574 squid[15911]: 1331576756.109 60653 192.168.0.253 TCP_MISS/000 0 GET http://gmail.com/ [^] - FIRST_UP_PARENT/havp -
Mar 12 23:56:00 efw-1331566574 squid[15911]: 1331576760.111 3352 192.168.0.253 TCP_MISS/000 0 GET http://gmail.com/ [^] - FIRST_UP_PARENT/havp -
Mar 12 23:56:14 efw-1331566574 squid[15911]: 1331576774.120 13579 192.168.0.253 TCP_MISS/000 0 GET http://gmail.com/ [^] - FIRST_UP_PARENT/havp -
Mar 12 23:56:16 efw-1331566574 squid[15911]: 1331576776.459 81000 127.0.0.1 TCP_MISS/503 2717 GET http://gmail.com/ [^] - DIRECT/173.194.36.21 text/html
Mar 12 23:56:44 efw-1331566574 squid[15911]: 1331576803.875 43332 127.0.0.1 TCP_MISS/000 0 GET http://gmail.com/ [^] - DIRECT/gmail.com -
Mar 12 23:56:44 efw-1331566574 squid[15911]: 1331576803.875 47114 127.0.0.1 TCP_MISS/000 0 GET http://gmail.com/ [^] - DIRECT/gmail.com -
Mar 12 23:57:07 efw-1331566574 squid[15911]: 1331576827.323 58 192.168.0.253 TCP_MISS/503 2792 GET http://alerts.conduit-services.com/root/799768/795587/IN [^] - FIRST_UP_PARENT/havp text/html
Mar 12 23:57:12 efw-1331566574 squid[15911]: 1331576832.691 2 192.168.0.253 TCP_MISS/503 3215 GET http://www.microsoft.com/isapi/redir.dll?prd=ie&pver=6&ar=msnhome [^] - NONE/- text/html
Mar 12 23:57:15 efw-1331566574 squid[15911]: 1331576835.291 0 192.168.0.253 TCP_MISS/503 3194 GET http://st.thetrafficstat.net/htm?s=780&md=20&sub=CT2405280 [^] - NONE/- text/html
Mar 12 23:57:15 efw-1331566574 squid[15911]: 1331576835.435 207 192.168.0.253 TCP_MISS/503 3284 GET http://d.foxadd.com/static/widget-fd.html?hash=203c5823c694f9ff31a1957976ccfb4e&template=201 [^] - NONE/- text/html
Mar 12 23:57:21 efw-1331566574 squid[15911]: 1331576841.699 2 192.168.0.253 TCP_MISS/503 3063 GET http://www.google.com/ [^] - NONE/- text/html
Mar 12 23:58:06 efw-1331566574 squid[30657]: 1331576886.581 57 192.168.0.253 TCP_MISS/503 2725 GET http://www.google.com/ [^] - FIRST_UP_PARENT/havp text/html



 
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0007759)
gennarom (reporter)
2012-03-17 18:33

See at 0004241 issue, same problem but no solution for now
(0007804)
davide-endian (developer)
2012-04-04 16:33
edited on: 2012-04-04 16:37

Hi,
can you provide any information that you think can be useful to spot the problem?

E.g.:
- uplink configuration (dhcp, static, gateway, ...)
- network configuration (DNS and gateway of both the endian and the client, network topogy, ...)
- involved zone: the client is on GREEN, BLUE, ORANGE, ...?
- DNS proxy configuration: on which interfaces it's active?
- HTTP proxy configuration: on which interfaces it's active? Transparent or not?

Thanks for your patience.


- Issue History
Date Modified Username Field Change
2012-03-13 05:16 amitk New Issue
2012-03-17 18:33 gennarom Note Added: 0007759
2012-04-04 16:33 davide-endian Note Added: 0007804
2012-04-04 16:33 davide-endian Assigned To => davide-endian
2012-04-04 16:33 davide-endian Status new => feedback
2012-04-04 16:37 davide-endian Note Edited: 0007804

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker