SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000437: PPP* uplink types need the possibility to supply "additional ip addresses" - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000437Endian FirewallNetwork related (VPN, uplinks)public2008-01-09 22:262008-10-08 13:30
ReporterSota 
Assigned Topeter-endian 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta2 
Target Version2.2-rc3Fixed in Version2.2-rc3 
Summary0000437: PPP* uplink types need the possibility to supply "additional ip addresses"
DescriptionI have a PPPOE connection with a block of 6 addresses assigned to me. On previous versions of Endian I could go to Network-Aliases to create aliases for the other addresses. This option is no longer available in Beta 2.
Additional InformationI tried editing /var/efw/ethernet/aliases manually but it doesn't seem to have any effect.
TagsNo tags attached.
Attached Files

- Relationships
parent of 0001057closedsimon-endian interfaceeditor: add the possibility to configure additional ips to each uplink type 
parent of 0001058closedsimon-endian netwizard: add the possibility to configure additional ip addresses 
parent of 0001059closedpeter-endian uplinks: scripts need to get rid of additional ip addresses 
parent of 0001060closedsimon-endian portfw: Incoming IP need possibility to select all the additional ip's 
parent of 0001061closedsimon-endian snat.cgi: get rid of additional ip addresses for each uplink 
has duplicate 0001164closedpeter-endian Do not multiple ip ( aliases ) submit. 

-  Notes
(0000759)
ra-endian (administrator)
2008-01-10 09:44

With version 2.2 you can add Aliases with the uplink editor Network -> Interfaces
(0000760)
Sota (reporter)
2008-01-10 10:52

When I try that, I get "Could not enable uplink. Maximum amount of PPPoE uplinks is reached".
(0000764)
peter-endian (administrator)
2008-01-10 11:21

I'm a little confused, because also in 2.1 it was not able to have aliases on PPPoE uplinks. Aliases were always only possible on STATIC uplinks.
Do you maybe have a STATIC uplink to an ethernet modem which then makes the PPPOE connection?

Aliases is gone completely, you can configure them now within the Interface editor by ticking on "Add additional addresses". But this option is available only with STATIC and PPTP uplink type.

We assume that ppp connections always receive the ip addresses from the provider. Maybe here it could be interesting to have also the possibility to add custom ip addresses, but we don't know if there are exist providers which allow custom ip address configuration by the user.
(0000766)
Sota (reporter)
2008-01-10 11:41

I know that it always said this was only for static uplinks but this always worked for me. I have an ADSL modem in bridging mode and my ISP has assigned me xxx.141.197.129 to xxx.141.197.142. By default, when Endian logs in, it gets the first address (.129)via DHCP from the ISP. If I then setup an alias for .130 I could ping that address externally. Even on beta 2 if I enter ifconfig ppp0:1 xxx.141.197.130, I can ping it externally. However, it does not appear as an interface under Firewall-Port Forwarding.
In IPCop 1.4 the same applied, except that the alias option was not on the menu, but you could navigate to the page manually and setup the alias.
(0000768)
peter-endian (administrator)
2008-01-10 11:53

interesting
ok,. this is going to be an interesting feature if providers really allow this.
i thought this would nobody need :)
we will include it.
(0000770)
Sota (reporter)
2008-01-10 11:58

Thank you. I look forward to testing it.
(0000771)
Sota (reporter)
2008-01-10 12:03

In the meantime, do you have any ideas on how I could manually add in the aliases?
(0000774)
peter-endian (administrator)
2008-01-10 18:14

we will add this later for version 2.3 since this basically is a new feature and we are currently in beta test state for 2.2

You can hardcode it manually by adding the following lines to
/etc/ppp/ip-up (before exit 0 of course):

ip addr add ipaddress/cidr dev $IFNAME
(0001476)
Byzt (reporter)
2008-07-29 07:08

Thank you Peter ;

We using version 2.1 Release on the product now .But we testing 2.2. beta and rc version. We Just This new alias problem to migrate 2.2 endian . Please 2.2 RC3 version add new alias ( multiple red ip ) .

- Issue History
Date Modified Username Field Change
2008-01-09 22:26 Sota New Issue
2008-01-09 22:26 Sota Status new => assigned
2008-01-09 22:26 Sota Assigned To => peter-endian
2008-01-10 09:42 ra-endian Assigned To peter-endian => ra-endian
2008-01-10 09:44 ra-endian Status assigned => resolved
2008-01-10 09:44 ra-endian Resolution open => no change required
2008-01-10 09:44 ra-endian Note Added: 0000759
2008-01-10 10:52 Sota Status resolved => feedback
2008-01-10 10:52 Sota Resolution no change required => reopened
2008-01-10 10:52 Sota Note Added: 0000760
2008-01-10 11:21 peter-endian Note Added: 0000764
2008-01-10 11:41 Sota Note Added: 0000766
2008-01-10 11:53 peter-endian Note Added: 0000768
2008-01-10 11:53 peter-endian Assigned To ra-endian => peter-endian
2008-01-10 11:53 peter-endian Status feedback => confirmed
2008-01-10 11:54 peter-endian Severity block => feature
2008-01-10 11:54 peter-endian Summary Alias option missing => PPP* uplink types need the possibility to supply "additional ip addresses"
2008-01-10 11:54 peter-endian Target Version => 2.3
2008-01-10 11:58 Sota Note Added: 0000770
2008-01-10 12:03 Sota Note Added: 0000771
2008-01-10 18:14 peter-endian Note Added: 0000774
2008-06-11 09:23 peter-endian Target Version 2.3 => 2.2
2008-06-12 10:48 peter-endian Target Version 2.2 => 2.2-rc1
2008-06-12 10:48 peter-endian Target Version 2.2-rc1 => 2.2-rc2
2008-06-25 13:52 raphael-endian Priority normal => immediate
2008-07-01 17:42 peter-endian Issue cloned: 0001057
2008-07-01 17:42 peter-endian Relationship added parent of 0001057
2008-07-01 17:43 peter-endian Issue cloned: 0001058
2008-07-01 17:43 peter-endian Relationship added parent of 0001058
2008-07-01 17:45 peter-endian Issue cloned: 0001059
2008-07-01 17:45 peter-endian Relationship added parent of 0001059
2008-07-01 17:45 peter-endian Severity feature => major
2008-07-01 17:49 peter-endian Issue cloned: 0001060
2008-07-01 17:49 peter-endian Relationship added parent of 0001060
2008-07-01 17:51 peter-endian Issue cloned: 0001061
2008-07-01 17:51 peter-endian Relationship added parent of 0001061
2008-07-24 16:06 ra-endian Target Version 2.2-rc2 => 2.2-rc3
2008-07-25 11:05 peter-endian Relationship added has duplicate 0001164
2008-07-28 10:44 peter-endian Priority immediate => urgent
2008-07-29 07:08 Byzt Note Added: 0001476
2008-08-11 15:43 peter-endian ETA none => < 1 month
2008-09-02 10:51 peter-endian Status confirmed => resolved
2008-09-02 10:51 peter-endian Fixed in Version => 2.2-rc3
2008-09-02 10:51 peter-endian Resolution reopened => fixed
2008-10-08 13:30 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker