SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000048: HTTP Proxy: Source subnet/ip/mac without authentication doesn't work (multiple lines) - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000048Endian FirewallApplication Level Proxiespublic2006-11-16 12:322008-02-02 07:28
Reporterra-endian 
Assigned Tora-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.1.2 
Target VersionFixed in Version2.2-beta2 
Summary0000048: HTTP Proxy: Source subnet/ip/mac without authentication doesn't work (multiple lines)
DescriptionSource subnet/ip/mac without authentication doesn't work (multiple lines)
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000512)
Anonymous (viewer)
2007-09-20 08:25
edited on: 2007-10-24 00:22

cannot work on 2.12

I can confirm the same problem exists with the box labeled "Source subnet/ip/mac without authentication (one per line)". This is a problem anytime more than one entry is entered in the textarea.

The problem seems to be in the way the settings file is being populated with the multiple values being added one per line.

The data needs to be "one per line" for the squid acl file (which is generated fine), but that format is inappropriate for the advanced settings file. This breaks restartsquid.py where the getconfig function is called and prevents squid from starting.

We have been able to hack around this by blanking the proxysettings('MAC_NOAUTH') variable in advproxy.cgi just before writing the settings file and repopulating it just before it writes the squid acl config.

This will be true for the "Domains without authentication (one per line):" textarea also, as the variables are populated and written using the same method.

(0000535)
Anonymous (viewer)
2007-10-24 00:24

I can confirm the same problem exists with the box labeled "Source subnet/ip/mac without authentication (one per line)". This is a problem anytime more than one entry is entered in the textarea.

The problem seems to be in the way the settings file is being populated with the multiple values being added one per line.

The data needs to be "one per line" for the squid acl file (which is generated fine), but that format is inappropriate for the advanced settings file. This breaks restartsquid.py where the getconfig function is called and prevents squid from starting.

We have been able to hack around this by blanking the proxysettings('MAC_NOAUTH') variable in advproxy.cgi just before writing the settings file and repopulating it just before it writes the squid acl config.

This will be true for the "Domains without authentication (one per line):" textarea also, as the variables are populated and written using the same method.
(0000779)
ra-endian (administrator)
2008-01-11 10:34

fixed with efw 2.2

- Issue History
Date Modified Username Field Change
2006-11-16 12:32 ra-endian New Issue
2006-11-16 12:33 ra-endian Status new => assigned
2006-11-16 12:33 ra-endian Assigned To => ra-endian
2006-11-16 12:33 ra-endian Status assigned => resolved
2006-11-16 12:33 ra-endian Fixed in Version => 2.1
2006-11-16 12:33 ra-endian Resolution open => fixed
2007-01-02 07:53 ra-endian Status resolved => closed
2007-09-20 08:25 Anonymous Status closed => feedback
2007-09-20 08:25 Anonymous Resolution fixed => reopened
2007-09-20 08:25 Anonymous Note Added: 0000512
2007-10-24 00:19 Anonymous Note Edited: 0000512
2007-10-24 00:22 Anonymous Note Edited: 0000512
2007-10-24 00:24 Anonymous Note Added: 0000535
2007-10-24 00:24 Anonymous Status feedback => confirmed
2008-01-11 09:17 ra-endian Product Version 2 => 2.1.2
2008-01-11 09:17 ra-endian Summary Domains without authenticationg => HTTP Proxy: Domains without authenticationg doesn't work
2008-01-11 10:34 ra-endian Status confirmed => resolved
2008-01-11 10:34 ra-endian Fixed in Version 2.1 => 2.2-beta2
2008-01-11 10:34 ra-endian Resolution reopened => fixed
2008-01-11 10:34 ra-endian Note Added: 0000779
2008-01-11 10:36 ra-endian Summary HTTP Proxy: Domains without authenticationg doesn't work => HTTP Proxy: Source subnet/ip/mac without authentication doesn't work (multiple lines)
2008-01-11 10:36 ra-endian Description Updated
2008-02-02 07:28 raphael-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker