SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0000512: dnsmasq will not be started on boot - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000512Endian FirewallOther Servicespublic2008-01-24 15:052010-11-22 11:49
Reporterpeter-endian 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-beta2 
Target Version2.4.1Fixed in Version2.4 
Summary0000512: dnsmasq will not be started on boot
Descriptiondnsmasq will not be started on boot
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000848)
peter-endian (administrator)
2008-01-24 16:12

cannot reproduce.. seems that this happens only some times
maybe related with uplinksdaemon hook. (will be restarted in addrchanged and in mainchanged, maybe that's the problem)
(0002793)
suds (reporter)
2009-07-27 13:31
edited on: 2009-07-27 13:32

My observation :

EndianVersion :

2.6.22.19-72.endian
Endian Firewall Community release 2.2


Its something to do with the order of start..
40blackholedns
40dnsmasq
40httpd
40openvpn
40ssh

In /etc/rc.d/start I changed 40dnsmasq to 45dnsmasq.
rebooted the endian..
This message "failed to load names from /etc/openvpn/dnsmasq.hosts.conf: No such file or directory" does not appear.


now I see this error :
Jul 27 18:53:21 endian sudo: root : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/usr/local/bin/restartdnsmasq.py --resolv-only

(0002800)
suds (reporter)
2009-07-28 03:54

I rebooted to test.. still it was not starting..
then I created the file : touch /etc/openvpn/dnsmasq.hosts.conf

now on reboot dnsmasq is starting.

- Issue History
Date Modified Username Field Change
2008-01-24 15:05 peter-endian New Issue
2008-01-24 15:05 peter-endian Target Version => 2.2-beta3
2008-01-24 15:43 peter-endian Summary /etc/init.d/dnsmasq status is missing => dnsmasq will not be started on boot
2008-01-24 15:43 peter-endian Description Updated
2008-01-24 16:12 peter-endian Note Added: 0000848
2008-01-30 11:31 ra-endian Status new => closed
2008-01-30 11:31 ra-endian Resolution open => unable to reproduce
2009-07-27 13:31 suds Note Added: 0002793
2009-07-27 13:31 suds Status closed => feedback
2009-07-27 13:31 suds Resolution unable to reproduce => reopened
2009-07-27 13:32 suds Note Edited: 0002793
2009-07-28 03:54 suds Note Added: 0002800
2010-09-20 18:27 peter-endian Target Version 2.2-beta3 => 2.4.1
2010-09-23 16:17 peter-endian Status feedback => acknowledged
2010-09-24 14:45 peter-endian Status acknowledged => resolved
2010-09-24 14:45 peter-endian Fixed in Version => 2.4
2010-09-24 14:45 peter-endian Resolution reopened => fixed
2010-09-24 14:45 peter-endian Assigned To => peter-endian
2010-11-22 11:49 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker